Bug 14510 - libtool runs configure in postinstall script
libtool runs configure in postinstall script
Status: CLOSED DEFERRED
Product: Red Hat Linux
Classification: Retired
Component: libtool (Show other bugs)
6.2
i386 Linux
medium Severity low
: ---
: ---
Assigned To: Jakub Jelinek
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-07-24 05:56 EDT by peter.benie
Modified: 2008-05-01 11:37 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-07-24 05:56:27 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description peter.benie 2000-07-24 05:56:25 EDT
Libtool runs configure in the postinstall script. This should really be
done while building the rpm so that files are already in the right places
for package installation.

I have noticed this because I am sharing /usr/doc between many machines,
using --exclude-path /usr/doc to prevent installation of files in that
directory. During the install, either /usr/doc is unavailable, in which
case I get one error from the postinstall script and config.h.in gets
placed in /, or /usr/doc is NFS mounted read-only, in which case I get many
errors from the postinstall script.
Comment 1 Jeff Johnson 2000-08-11 11:50:35 EDT
Libtool runs autoconf et al in %post so that the libtool demo works correctly.

Doing this in the buildroot, rather than in %post, is quite painful. I'd say
rather that
libtool should not have the demo source code in the doc directory which is of
limited utility. Meanwhile, I'll leave well enough alone for now.

Note You need to log in before you can comment on or make changes to this bug.