Bug 145128 - hwclock timed out on recent kernels and sync problems
hwclock timed out on recent kernels and sync problems
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
4
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Dave Jones
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-01-14 11:44 EST by Peter Lucas
Modified: 2015-01-04 17:15 EST (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-11-21 11:48:56 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Peter Lucas 2005-01-14 11:44:37 EST
Description of problem:

In kernel2.6.10-1.741 and 2.6.10-1.737 the hw clock cannot be
read and it is also no longer possible sync the hw clock.
There were no problems in previous kernels, e.g. 
2.6.9-1.724 and 2.6.9-1.681

Version-Release number of selected component (if applicable):

kernel2.6.10-1.741 and 2.6.10-1.737 

How reproducible:

type in hwclock --show

result is timed out message; kernel 2.6.9-1.724 gives the right
hw time.

Steps to Reproduce:
1. hwclock --show
2. 
3.
  
Actual results:

select() /dev/rst timed out

Expected results:

Fri 14 Jan 2005 05:35:11 PM CET  -0.015968 seconds

Additional info:

Worked without problems until I updated to the latest two kernels.
It still worked if I use an earlier kernel, as mentioned above.
Comment 1 Peter Jones 2005-01-21 17:20:31 EST
Somehow this got filed against syslinux.  Reassigning to kernel.
Comment 2 Patrick Jon Cooney 2005-02-08 18:19:31 EST
I have posted a 'workaround', used on a Dell Dimension P4 w/ HT 
supported and enabled running kernel/-smp 2.6.10-1.741_FC3, in bug 
#144894.
Comment 3 Steve Nielsen 2005-02-16 12:39:03 EST
This bug occurs on fedora core 2 (kernel 2.6.10-1.9_FC2smp). on all my
dell 2850s. The default kernel 2.6.5-1.358smp (before doing updates)
works. I was able to work around this problem by implementing the
workaround above.
Comment 4 Bill McGonigle 2005-04-07 09:38:21 EDT
Dup of bug 144894?
Comment 5 Forest Wilkinson 2005-05-03 12:38:04 EDT
This also occurs on a Dell Dimension 8400, under the released version of Fedora
Core 3, with the 2.6.11-1.14_FC3smp kernel.

Another mention on the debian kernel list:
http://lists.debian.org/debian-kernel/2004/12/msg00381.html
Comment 6 Dave Jones 2005-06-27 19:19:03 EDT
Mass update of -test bugs to update version to fc4.
(Please retest on final release, and report results if you have not already done
so).

Thanks.
Comment 7 Christophe Lambin 2005-08-16 14:48:06 EDT
This indeed looks like a dupe of bug #144894.
Comment 8 Dave Jones 2005-09-30 02:58:34 EDT
Mass update to all FC4 bugs:

An update has been released (2.6.13-1.1526_FC4) which rebases to a new upstream
kernel (2.6.13.2). As there were ~3500 changes upstream between this and the
previous kernel, it's possible your bug has been fixed already.

Please retest with this update, and update this bug if necessary.

Thanks.
Comment 9 Dave Jones 2005-11-10 15:04:27 EST
2.6.14-1.1637_FC4 has been released as an update for FC4.
Please retest with this update, as a large amount of code has been changed in
this release, which may have fixed your problem.

Thank you.
Comment 10 Christophe Lambin 2005-11-19 03:34:49 EST
This is fixed in 2.6.14-1.1637_FC4

Note You need to log in before you can comment on or make changes to this bug.