Bug 145133 - ACPI button recognized but does not work
ACPI button recognized but does not work
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
3
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Dave Jones
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-01-14 12:19 EST by Jurgen Kramer
Modified: 2015-01-04 17:15 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-10-28 12:22:43 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jurgen Kramer 2005-01-14 12:19:59 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.5)
Gecko/20041111 Firefox/1.0

Description of problem:
On my HP TC1100 (Tablet PC) the ACPI power button is recognized but
pressing it does not result in a proper button/power event which can
be used by acpid to power down the machine.

Running the kernel with ACPI debugging enabled shows some GPE activity
when I press the button.

BTW the button does not work with previous kernel versions either.


Version-Release number of selected component (if applicable):
kernel-2.6.10-1.741_FC3

How reproducible:
Always

Steps to Reproduce:
1. Press power button when booted in FC3
2. == nothing happens ==
3.
    

Actual Results:  Nothing happens. /var/log/acpid does not show the
expected event.

Expected Results:  Machine should power down via ACPI event.

Additional info:
Comment 1 Dave Jones 2005-07-15 16:05:07 EDT
An update has been released for Fedora Core 3 (kernel-2.6.12-1.1372_FC3) which
may contain a fix for your problem.   Please update to this new kernel, and
report whether or not it fixes your problem.

If you have updated to Fedora Core 4 since this bug was opened, and the problem
still occurs with the latest updates for that release, please change the version
field of this bug to 'fc4'.

Thank you.
Comment 2 Jurgen Kramer 2005-07-16 06:11:59 EDT
I've updated to kernel 2.6.12-1.1372. Unfortunately pressing the power button
does not result in a button/power ACPI event. I can only see battery events in
/var/log/acpid.
Comment 3 Jurgen Kramer 2005-10-28 12:22:43 EDT
More current kernels seem to detect the power button twice:

ACPI: Power Button (FF) [PWRF]
ACPI: Power Button (CM) [PWRB]

Checking the acpid logs, the latter seems to be responsible for the now working
power button..case closed!



Note You need to log in before you can comment on or make changes to this bug.