Bug 145175 - kernel install fails due to "missing" sym53c8xx_2.ko
kernel install fails due to "missing" sym53c8xx_2.ko
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
3
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Dave Jones
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-01-14 19:06 EST by Vladimir Ivanovic
Modified: 2015-01-04 17:15 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-01-15 21:55:59 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Vladimir Ivanovic 2005-01-14 19:06:49 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.5)
Gecko/20041111 Firefox/1.0

Description of problem:
I have to run the following script after every kernel installation:

#!/bin/sh

[ -n ${1} ] || {
	echo "Usage: $0 <kernel-release>"
	exit -1
}

[ -d /lib/modules/${1}/kernel/drivers/scsi ] || { 
	echo "/lib/modules/${1} not found"
	exit -1
}

cd /lib/modules/${1}/kernel/drivers/scsi

mv sym53c8xx_2/sym53c8xx.ko .
rmdir sym53c8xx_2/
mv sym53c8xx.ko sym53c8xx_2.ko

/sbin/new-kernel-pkg --package kernel-smp --mkinitrd --depmod
--install ${1}


Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. rpm -ivh <any kernel>
2.
3.
    

Actual Results:  
Installing...
   1:hal                   
########################################### [100%]
   2:kernel-smp            
########################################### [100%]
WARNING: No module sym53c8xx_2 found for kernel 2.6.10-1.741_FC3smp,
continuing anyway


Expected Results:  A successful install.

Additional info:

See description.
Comment 1 Dave Jones 2005-01-14 23:54:52 EST
whats in your /etc/modprobe.conf ?
Comment 2 Vladimir Ivanovic 2005-01-15 01:54:39 EST
Contents of /etc/modprobe.conf:

# Note: for use under 2.4, changes must also be made to modules.conf!
alias parport_lowlevel parport_pc
alias eth0 e100
alias scsi_hostadapter sym53c8xx_2
options loop max_loop=64  
options ide-cd dma=1  
alias sound-slot-0 es1371
install dm-mod /sbin/modprobe --first-time --ignore-install dm-mod &&
{ /etc/rc.d/init.d/devmap_mknod.sh; }
install sound-slot-0 /sbin/modprobe --first-time --ignore-install
sound-slot-0 && { /bin/aumix-minimal -f /etc/.aumixrc -L >/dev/null
2>&1 || :; }
remove sound-slot-0 { /bin/aumix-minimal -f /etc/.aumixrc -S
>/dev/null 2>&1 || :; } ; /sbin/modprobe -r --first-time
--ignore-remove sound-slot-0
#options hangcheck_timer hangcheck_reboot=1  

---------
BTW, I have dual LSI Logic/Symbios Logic 53c1010 Ultra3 SCSI Adapters.
Comment 3 Dave Jones 2005-01-15 01:58:18 EST
if you change

alias scsi_hostadapter sym53c8xx_2

to

alias scsi_hostadapter sym53c8xx

it should work without you needing to munge anything.
Did anaconda set up that modprobe.conf ?
Comment 4 Vladimir Ivanovic 2005-01-15 02:08:25 EST
I don't know if anaconda did that. I don't recall setting it up
myself, but I know I haven't had this problem prior to FC3.

A question: Isn't there a versiom  1 of sym53x8xx and won't I be
getting that version instead of version 2?
Comment 6 Vladimir Ivanovic 2005-01-15 16:19:17 EST
I tried using

   alias scsi_hostadapter sym53c8xx

in /etc/modprobe.con

with 2.6.10-1.741_FC3smp, and it works.

I'm leaving the bug open because I don't know what you folks want to
do wrt FC3/anaconda etc., but AFAIC, you may close it.

Thanks.
Comment 7 Dave Jones 2005-01-15 21:55:59 EST
the kernel spec had a missing module_upgrade call, which changes
modules names when migrating from one kernel to another, so when you
moved this box from 2.4 kernel to 2.6, it kept using the 2.4 module name.

in 2.6 however, the old sym driver got removed, and the _2 driver
became the regular driver.

Future FC's should do 2.4 -> 2.6 migrations automatically, though it's
a little late now, and I guess most people either fixed up by hand, or
for whatever reason, never noticed anything go wrong.

Note You need to log in before you can comment on or make changes to this bug.