Bug 145238 - CPIO won't back up files >2G
CPIO won't back up files >2G
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: cpio (Show other bugs)
3
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Peter Vrabec
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-01-15 14:33 EST by sean fulton
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-01-18 04:31:05 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description sean fulton 2005-01-15 14:33:04 EST
Description of problem:
CPIO will not back up files >2G, but tar does.

Version-Release number of selected component (if applicable):
RH9, used cpio 2.5-3 that came with it, problem still exists in 2.5-7
from FC-3

How reproducible:
Create a file 11Gbytes in size
ls | cpio -ov -O/tmp/output.cpio
Error message is: 
cpio: it_ag_search.tar: Value too large for defined data type

Downloaded the SRPM, re-compiled with "-D_FILE_OFFSET_BITS=64
-D_LARGEFILE_SOURCE -D_LARGEFILE64_SOURCE"

New error message is:
cpio: File it_ag_search.tar grew, 0 new bytes not copied

(The file did not grow)

BTW: The ls is used simply for testing. Our backup scripts, which
first caught this error, use find . -print | cpio

I saw a similar bug posted here, but the poster seemed to think the
bug was from find. It's not; the same error comes up using find or ls.

And tar -cvf tarfile.tar it_ag_sarch.tar works fine

sean


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Peter Vrabec 2005-01-17 09:12:19 EST
I tried latest cpio-2.6-3 from development.
Back up 6.5GB file with no problems.
Comment 2 sean fulton 2005-01-17 09:45:03 EST
Where can I get this?
Comment 3 sean fulton 2005-01-17 10:18:04 EST
I found it. Download cpio-2.6-2 from fedora development and it seems
to be working.

sean
Comment 4 sean fulton 2005-01-17 10:30:26 EST
I take that back. cpio-2.6-2 running on RedHat 9 still produces the
following error:

cpio: File lnxdb1.cpio grew, 0 new bytes not copied
lnxdb1.cpio is an 11 Gbyte file.

Ideas?
Comment 5 Peter Vrabec 2005-01-18 04:31:05 EST
Use FC3 with the newest cpio-2.6-3(should appear in development soon).
I test it on 13GB of data.
Comment 6 sean fulton 2005-01-18 12:23:42 EST
I think the issue is with the glibc. I compiled cpio-2.6.2 with
glibc-2.3.2. When I tried to install the RPM version of 2.6.2, it
complained that I needed to upgrade to glibc-2.3.4, which is a pain on
RH 9.

Any suggestions?

sean
Comment 7 sean fulton 2005-01-18 19:24:20 EST
I just upgraded to glibc2.3.4 and installed cpio-2.6.3 and am getting
the same error about 

cpio: File lnxdb1.cpio grew, 0 new bytes not copied
lnxdb1.cpio is an 11 Gbyte file.

The file has not grown, so something is still screwed up.

sean

Note You need to log in before you can comment on or make changes to this bug.