Bug 145261 - Add/Remove Applications cannot remove anything
Add/Remove Applications cannot remove anything
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: system-config-packages (Show other bugs)
3
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Jeremy Katz
Mike McLean
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-01-15 23:06 EST by James Ryley
Modified: 2007-11-30 17:10 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-09-21 15:56:11 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description James Ryley 2005-01-15 23:06:31 EST
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1; SV1)

Description of problem:
When accessing the Add/Remove Application menu in the Gnome desktop, 
not a single component can actually be removed.  Every one give the 
error:

"The following packages could not be found on your system.  
Installation cannot continue until they are installed."

This message is followed by a list of components.  Sometimes this 
list has 2 or 3 entries, sometimes it has dozens.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Open Add/Remove Applications
2. Uncheck any component
3. Press the update button
    

Actual Results:  Error message "The following packages could not be 
found on your system.  Installation cannot continue until they are 
installed."

Expected Results:  Component removal.

Additional info:

This function literally does not work for a single component.  I am 
scratching my head wondering what the purpose of this function 
actually is, or if I am doing something wrong...
Comment 1 James Ryley 2005-01-17 14:43:43 EST
By the way, after doing some research on this, I assume that it 
happens because updates have been installed, so it doesn't find the 
exact package versions it wants.  However, given that the first thing 
most people do is probably get all the current updates after 
installing, that renders this function useless.  Yum works fine if 
you want to uninstall dozens (or hundreds) of packages by hand.  
Perhaps the Add/Remove Package function could just queue things up in 
yum.
Comment 2 Yonatan 2005-04-10 07:08:06 EDT
I have the same problem except that some applications can install and be
uninstalled(In certain situations, more on this soon). When checking Windows
File Server and clicking on 'update' it will produce an error identical to james'
"Package Not found"
The following package could not be found on your system.  Installation cannot
continue until it is installed.
Unlocatable package |  Required by
samba-common           ('samba-client','3.0.10','1.fc3')
-------
Using yum I checked and both these are installed, including samba-common. samba
client version number is the exact same as in the error message. Now what's
interesting is that now when I untick 'Windows file server' and try install any
other app I get the same error as above but with this:
Unlocatable package |  Required by
samba-client           ('authconfig-gtk','4.6.5','3.1')


Comment 3 Jeremy Katz 2005-09-21 15:56:11 EDT
Yeah, current system-config-packages doesn't handle updates very well at all. 
The next generation tool being targeted for FC5 will work far better for these cases

Note You need to log in before you can comment on or make changes to this bug.