Bug 145263 - Anaconda does not recognize Seagate SATA Hard Drive
Anaconda does not recognize Seagate SATA Hard Drive
Status: CLOSED CANTFIX
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
3
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Jeff Garzik
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-01-16 00:44 EST by Don Beck
Modified: 2013-07-02 22:23 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-10-02 21:15:54 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Don Beck 2005-01-16 00:44:17 EST
Description of problem:
Anaconda does not recognize Seagate SATA Hard Drive with Nvidia sata_nv

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.Try to Install Fedora Core 3 from DVD
2.
3.
  
Actual results:
Install will not recognize the Seagate SATA Hard Drive

Expected results:
Install should recognize the Seagate SATA Hard Drive, allow you to
partition & format the Hard Drive, and install to it.

Additional info:
Using the exact same hardware, Fedora Core 2 installation CD does
recognize the Seagate SATA Hard Drive.
Comment 1 Don Beck 2005-01-16 00:55:29 EST
This problem is being discussed at
http://www.linuxquestions.org/questions/showthread.php?s=&threadid=276829
There are presently 3 people who have posted there that have the
combination of Fedora Core 3, Nvidia chip set with native SATA, and
Seagate SATA Hard drives, and the hard drives are not being recognized
by anaconda.  I used the Fedora Core 2 installation CD with the same
hardware, and the Seagate Sata Hard Drive was properly recognized.  I
also used a SATA/PATA adapter to hook a Western Digital PATA hard
drive to the SATA controller, and Fedora Core 3 loaded the sata_nv
driver and recognized the Western Digital properly.
Comment 2 Rohan 2005-01-16 08:16:07 EST
Got the same problem with a Seagate 80gb SATA, and Nvidia nforce3 chipset.

Anaconda loads sata_nv
Prompts to select a harddrive of which the sata is one option.
Flags an error saying it has no place to install to and exits.
Comment 3 Borkur Steingrimsson 2005-01-16 09:50:33 EST
I have the same problem and have tried several ways to upgrade from
FC2 to FC3. My AMD Semphron 3200+ box with the SATA Barracuda runs
fine on the current FC2 but trying to upgrade to FC2 I run into the
same problems. Currently I get the drive detected (in BIOS) as the 3rd
IDE master, and the drive gets mounted as /dev/hde. After creating a
boot image from the FC3 cd, burning and installing or trying upgrade
(linux upgrades) I always get the same error.

borkur
Comment 4 Taso Hatzi 2005-02-08 01:34:31 EST
FWIW, the SuSE 9.2 installer has the same problem.
Comment 5 Taso Hatzi 2005-02-08 19:09:01 EST
I replaced my Seagate with a Western Digital and it appears to work
now, so it seems to be a problem with Seagate drives.

The Seagate that is not detected is a fairly new (ie has NCQ stuff)
160GB . The Western Digital is an older 80GB.
Comment 6 Jason 2005-02-20 01:46:32 EST
I have a small twist.  I have an ASUS A7N8X Deluxe (r2) motherboard
with a Silicon Image 3112 controller and the installer just hangs when
it tries to load the sata_sil driver with the message: Disabling
IRQ11.  Currently it doesn't matter what type of SATA drive I use, I
just cannot get FC3 installed at all.
Comment 7 pritam ghanghas 2005-03-19 02:33:55 EST
i have the same problem with fc3 and sata 120GB seagate. it says that it didn't
find any hdd to install to
Comment 8 basiegel 2005-04-04 17:47:38 EDT
I have a Seagate 80 gig, and a Radeon 9800 pro.  The installer recognizes my
secondary hdd, and i got fedora to install on it, but it also puts the /boot
file  there.  I severely need a patch so I can run linux (I would like free
email and web hosting). 
Comment 9 Dave Jones 2005-07-15 16:41:16 EDT
An update has been released for Fedora Core 3 (kernel-2.6.12-1.1372_FC3) which
may contain a fix for your problem.   Please update to this new kernel, and
report whether or not it fixes your problem.

If you have updated to Fedora Core 4 since this bug was opened, and the problem
still occurs with the latest updates for that release, please change the version
field of this bug to 'fc4'.

Thank you.
Comment 10 Dave Jones 2005-10-02 21:15:54 EDT
This bug has been automatically closed as part of a mass update.
It had been in NEEDINFO state since July 2005.
If this bug still exists in current errata kernels, please reopen this bug.

There are a large number of inactive bugs in the database, and this is the only
way to purge them.

Thank you.

Note You need to log in before you can comment on or make changes to this bug.