Bug 14528 - DDS-4 tape drive not recognized by mt
DDS-4 tape drive not recognized by mt
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
6.2
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Doug Ledford
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-07-24 10:28 EDT by Mark Cate
Modified: 2008-05-01 11:37 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-12-14 19:21:51 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Mark Cate 2000-07-24 10:28:26 EDT
The tape drive is a Dell PowerVault 100T DDS4 on Adaptec AIC-7890 controller.  The box is a Dell PowerEdge 1300.  All hardware has 
been verified ok by Dell tech support.  The drive is located at scsi id 6 with default switch & jumper settings.

The box is at kernel 2.2.16-3smp, and all released updates have been applied.  Support for aic7xxx is included in the kernel, as is Enable TCQ 
by default. Max TCQ per device is at 24, however I have tried 8 & 16 with no result.  The delay on scsi bus is at 15.  Also included is SCSI 
debuging host adapter.

I am able to write to a DDS-4 tape with tar.  Prior to including scsi debuging host adapter I was not.
The only mt commands that the drive has responded to are status, tell and rewoffl.

# mt -t /dev/nst0 status
SCSI 2 tape drive:
File number=0, block number=0, partition=0.
Tape block size 512 bytes. Density code 0x26 (unknown to this mt).
Soft error count since last status=0
General status bits on (41010000):
 BOT ONLINE IM_REP_EN     

An attempt to erase a tape will lock the drive and result in:
Jul 20 10:28:48 poweredge kernel: st0: Error with sense data: [valid=0] Info fld=0x0, Current st09:00: sense key Medium Error 
Jul 20 10:28:48 poweredge kernel: Additional sense indicates Sequential positioning error 

Any attempt to access the drive results in an I/O error, the only way to get the drive back at that point is to power off.

The first indication of a problem with is at boot time, the following is a snip from dmesg:
Jul 20 07:58:52 poweredge kernel: (scsi1) <Adaptec AIC-7890/1 Ultra2 SCSI host adapter> found at PCI 2/11/0 
Jul 20 07:58:52 poweredge kernel: (scsi1) Wide Channel, SCSI ID=7, 32/255 SCBs 
Jul 20 07:58:52 poweredge kernel: (scsi1) Downloading sequencer code... 392 instructions downloaded 
Jul 20 07:58:52 poweredge kernel: scsi1 : Adaptec AHA274x/284x/294x (EISA/VLB/PCI-Fast SCSI) 5.1.30/3.2.4 
Jul 20 07:58:52 poweredge kernel:        <Adaptec AIC-7890/1 Ultra2 SCSI host adapter> 
Jul 20 07:58:52 poweredge kernel: scsi : 2 hosts. 
Jul 20 07:58:52 poweredge kernel: (scsi1:0:6:0) invalid cur_addr:0x793404e during WIDE_RESIDUE 
Jul 20 07:58:52 poweredge kernel: (scsi1:0:6:0)   sg_address[-1]:0x0 sg_length[-1]:0 
Jul 20 07:58:52 poweredge kernel: (scsi1:0:6:0)   sg_address:0x0 sg_length:0 
Jul 20 07:58:52 poweredge kernel: (scsi1:0:6:0)   cur_address:0x793404e resid_dcnt:0x0000d1 
Jul 20 07:58:52 poweredge kernel: (scsi1:0:6:0) Synchronous at 40.0 Mbyte/sec, offset 32. 
Jul 20 07:58:52 poweredge kernel: (scsi1:0:6:0) invalid cur_addr:0x793404e during WIDE_RESIDUE 
Jul 20 07:58:52 poweredge kernel: (scsi1:0:6:0)   sg_address[-1]:0x0 sg_length[-1]:0 
Jul 20 07:58:52 poweredge kernel: (scsi1:0:6:0)   sg_address:0x0 sg_length:0 
Jul 20 07:58:52 poweredge kernel: (scsi1:0:6:0)   cur_address:0x793404e resid_dcnt:0x0000d1 
Jul 20 07:58:52 poweredge kernel: (scsi1:0:6:0) invalid cur_addr:0x7fa7e1e during WIDE_RESIDUE 
Jul 20 07:58:52 poweredge kernel: (scsi1:0:6:0)   sg_address[-1]:0x0 sg_length[-1]:0 
Jul 20 07:58:52 poweredge kernel: (scsi1:0:6:0)   sg_address:0x0 sg_length:0 
Jul 20 07:58:52 poweredge kernel: (scsi1:0:6:0)   cur_address:0x7fa7e1e resid_dcnt:0x0000d2 
Jul 20 07:58:52 poweredge kernel:   Vendor: ARCHIVE   Model: Python 06408-XXX  Rev: 8071 
Jul 20 07:58:52 poweredge kernel:   Type:   Sequential-Access                  ANSI SCSI revision: 03
Comment 1 Need Real Name 2000-10-05 13:56:47 EDT
I am having the same problem, however the hardware is a bit different.  We are 
running a Gateway 7210 server, AIC-7896N controller, and a Seagate Scorpion 40 
(STD2401LW) DDS-4 TBU.  The behavior is very similar in that I too can write 
but any attemp to restore or list from the archive is fatal.  The system was a 
fresh install of RH6.2 retail.
Comment 2 Jeff Johnson 2001-01-06 15:07:09 EST
This appears to be a kernel driver issue.
Comment 3 Need Real Name 2002-12-04 13:10:22 EST
This is not a kernel (or Linux) issue.  It is an incompatibility between the
Adaptec aic789x chipsets and tape drives.  More detailed information can be
located in bugzilla bug 75916 or at http://www.linuxtapecert.org.

Tim

Note You need to log in before you can comment on or make changes to this bug.