Bug 145280 - Error inserting bttv
Error inserting bttv
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
3
i686 Linux
medium Severity high
: ---
: ---
Assigned To: Dave Jones
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-01-16 16:57 EST by Boril Gourinov
Modified: 2015-01-04 17:15 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-09-28 04:20:09 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Boril Gourinov 2005-01-16 16:57:31 EST
Description of problem: loading of bttv driver fails when upgrade to
kernel 2.6.10-1.741 from 2.6.9-1.742 with yum


Version-Release number of selected component (if applicable):
2.6.10-1.741

How reproducible:
modprobe bttv

Steps to Reproduce:
1.upgrade to kernel 2.6.10-1.741 from 2.6.9-1.742 with yum
2.modprobe bttv
3.
  
Actual results:
FATAL: Error inserting bttv
(/lib/modules/2.6.10-1.741_FC3/kernel/drivers/media/video/bttv.ko):
Unknown symbol in module, or unknown parameter (see dmesg)

Expected results:
loading bttv driver without problems

Additional info:
Athlon t-burd 650 MHz 256 MB RAM
Comment 1 Boril Gourinov 2005-01-16 17:00:56 EST
#modprobe bttv
FATAL: Error inserting bttv
(/lib/modules/2.6.10-1.741_FC3/kernel/drivers/media/video/bttv.ko):
Unknown symbol in module, or unknown parameter (see dmesg)

#dmesg says
i2c /dev entries driver
bttv: Unknown parameter `'
bt878: Unknown symbol bttv_read_gpio
bt878: Unknown symbol bttv_write_gpio
bt878: Unknown symbol bttv_gpio_enable
bttv: Unknown parameter `'
bttv: Unknown parameter `'
tuner: Unknown parameter `'
tvaudio: Unknown parameter `'
bttv: Unknown parameter `'
bttv: Unknown parameter `'
bttv: Unknown parameter `'
bttv: Unknown parameter `'

my modprobe.conf is:

alias char-major-81 bt878
alias char-major-81-0 bttv
options bttv card=72 radio=1  
options tuner debug=1  
options tvmixer devnr=1  
options tvaudio tda9874a=1 tda9874a_STD=6 tda9874a_AMSEL=0
Comment 2 Dave Jones 2005-07-15 14:24:56 EDT
An update has been released for Fedora Core 3 (kernel-2.6.12-1.1372_FC3) which
may contain a fix for your problem.   Please update to this new kernel, and
report whether or not it fixes your problem.

If you have updated to Fedora Core 4 since this bug was opened, and the problem
still occurs with the latest updates for that release, please change the version
field of this bug to 'fc4'.

Thank you.

Note You need to log in before you can comment on or make changes to this bug.