Bug 145302 - xfce dependency problems when updating
xfce dependency problems when updating
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: libxfce4mcs (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Ngo Than
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-01-17 02:26 EST by Richard Hally
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-06-13 17:09:10 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Richard Hally 2005-01-17 02:26:43 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.5)
Gecko/20041228 Firefox/1.0 Fedora/1.0-8

Description of problem:
When trying to update xfce to the latest packages in /development,
there are messed up dependencies that make the update fail. see the
output from yum update below.

Version-Release number of selected component (if applicable):
4.1.99 and 4.0.6

How reproducible:
Always

Steps to Reproduce:
1. point yum to the development repository
2. yum update
3.
    

Actual Results:  [root@new2 ~]# yum --exclude=cpio update
Setting up Update Process
Setting up Repo:  development
repomd.xml                100% |=========================| 1.1 kB    00:00
Reading repository metadata in from local files
developmen: ################################################## 3691/3691
Excluding Packages in global exclude list
Finished
Resolving Dependencies
--> Populating transaction set with selected packages. Please wait.
---> Package xfce-utils.i386 0:4.0.6-3 set to be updated
---> Package xfce-mcs-manager.i386 0:4.1.99.1-1 set to be updated
---> Package xfce-mcs-manager-devel.i386 0:4.1.99.1-1 set to be updated
---> Package libxfcegui4.i386 0:4.1.99.1-1 set to be updated
---> Package libxfce4mcs-devel.i386 0:4.1.99.1-1 set to be updated
---> Package libxfce4mcs.i386 0:4.1.99.1-1 set to be updated
---> Package xfce-mcs-plugins.i386 0:4.1.99.1-1 set to be updated
---> Package libxfce4util.i386 0:4.1.99.1-1 set to be updated
--> Running transaction check
--> Processing Dependency: libxfce4mcs-client.so.1 for package:
xfce4-iconbox
--> Processing Dependency: libxfcegui4.so.1 for package: xfce4-iconbox
--> Processing Dependency: libxfcegui4.so.1 for package: xfce4-systray
--> Processing Dependency: libxfce4mcs-manager.so.1 for package:
xfce4-iconbox
--> Processing Dependency: libxfce4mcs-client.so.1 for package: xffm
--> Processing Dependency: libxfce4mcs-client.so.1 for package: xfce-utils
--> Processing Dependency: libxfce4mcs-manager.so.1 for package:
xfce-utils
--> Processing Dependency: libxfce4mcs-client.so.1 for package:
xfce4-panel
--> Processing Dependency: libxfcegui4.so.1 for package: xfprint
--> Processing Dependency: libxfcegui4.so.1 for package: xffm
--> Processing Dependency: libxfcegui4.so.1 for package: xfwm4
--> Processing Dependency: libxfce4mcs-client.so.1 for package: xfdesktop
--> Processing Dependency: libxfce4mcs-manager.so.1 for package:
xfce4-panel
--> Processing Dependency: libxfce4mcs-manager.so.1 for package: xffm
--> Processing Dependency: libxfce4mcs-client.so.1 for package: xfwm4
--> Processing Dependency: libxfcegui4.so.1 for package: xfce-utils
--> Processing Dependency: libxfcegui4.so.1 for package: xfce4-panel
--> Processing Dependency: libxfcegui4.so.1 for package: xfdesktop
--> Finished Dependency Resolution
Error: missing dep: libxfce4mcs-client.so.1 for pkg xfce4-iconbox
Error: missing dep: libxfcegui4.so.1 for pkg xfce4-iconbox
Error: missing dep: libxfcegui4.so.1 for pkg xfce4-systray
Error: missing dep: libxfce4mcs-manager.so.1 for pkg xfce4-iconbox
Error: missing dep: libxfce4mcs-client.so.1 for pkg xffm
Error: missing dep: libxfce4mcs-client.so.1 for pkg xfce-utils
Error: missing dep: libxfce4mcs-manager.so.1 for pkg xfce-utils
Error: missing dep: libxfce4mcs-client.so.1 for pkg xfce4-panel
Error: missing dep: libxfcegui4.so.1 for pkg xfprint
Error: missing dep: libxfcegui4.so.1 for pkg xffm
Error: missing dep: libxfcegui4.so.1 for pkg xfwm4
Error: missing dep: libxfce4mcs-client.so.1 for pkg xfdesktop
Error: missing dep: libxfce4mcs-manager.so.1 for pkg xfce4-panel
Error: missing dep: libxfce4mcs-manager.so.1 for pkg xffm
Error: missing dep: libxfce4mcs-client.so.1 for pkg xfwm4
Error: missing dep: libxfcegui4.so.1 for pkg xfce-utils
Error: missing dep: libxfcegui4.so.1 for pkg xfce4-panel
Error: missing dep: libxfcegui4.so.1 for pkg xfdesktop
You have new mail in /var/spool/mail/root
[root@new2 ~]# rpm -qa |grep xfce
xfce-mcs-manager-devel-4.0.6-2
libxfce4util-4.0.6-1
xfce4-iconbox-4.0.6-2
xfce-utils-4.0.6-1
libxfcegui4-4.0.6-1
xfce-mcs-manager-4.0.6-2
xfce4-systray-4.0.6-2
xfce-mcs-plugins-4.0.6-2
xfce4-panel-4.0.6-1
libxfce4mcs-devel-4.0.6-1
libxfce4mcs-4.0.6-1
[root@new2 ~]#


Expected Results:  expected that all the xfce components would update
to the latest varsions.

Additional info:

here are the currently installed versions related to xfce.

[root@new2 ~]# rpm -qa |grep xfce
xfce-mcs-manager-devel-4.0.6-2
libxfce4util-4.0.6-1
xfce4-iconbox-4.0.6-2
xfce-utils-4.0.6-1
libxfcegui4-4.0.6-1
xfce-mcs-manager-4.0.6-2
xfce4-systray-4.0.6-2
xfce-mcs-plugins-4.0.6-2
xfce4-panel-4.0.6-1
libxfce4mcs-devel-4.0.6-1
libxfce4mcs-4.0.6-1
[root@new2 ~]#

Note You need to log in before you can comment on or make changes to this bug.