Bug 145321 - [kde] kdefilechooser freezes when double-clicking to open a file
[kde] kdefilechooser freezes when double-clicking to open a file
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: openoffice.org (Show other bugs)
3
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Caolan McNamara
:
: 150955 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-01-17 09:22 EST by Martin Høy
Modified: 2007-11-30 17:10 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-04-08 10:23:50 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Martin Høy 2005-01-17 09:22:35 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.5)
Gecko/20041111 Firefox/1.0

Description of problem:
When opening an existing document by double-clicking on it in the
kdefilepicker dialog, openoffice freezes.

But if I single-click on the file and then click the "OK"-button,
the file opens as expected.

Version-Release number of selected component (if applicable):
openoffice.org-1.1.2-11.5.fc3

How reproducible:
Always

Steps to Reproduce:
1. Start oowriter (or any other, like oocalc)
2. Choose File->Open.
3. Double-click on the file you want to open in the filechooser.
    

Actual Results:  The filechooser and/or oowriter freezes

Expected Results:  The file should be opened.

Additional info:
Comment 1 Caolan McNamara 2005-01-18 06:34:24 EST
What's your kde theme, e.g. baghira ? this might be the same as bug 133487.
Comment 2 Martin Høy 2005-01-18 06:57:49 EST
My kde theme is the standard BlueCurve theme. The machine is running an
up-to-date updated version of FC3 (i.e. kde-3.3.1-4.3.FC3).

The error is present with both the original and updated version of
openoffice.org (i.e. both 1.1.2-10 and 1.1.2-11.5.fc3).

I think the error is a deadlock of some kind: When running an strace on
the oowriter process, the last lines in the strace-window is:

gettimeofday({1106048422, 446396}, NULL) = 0
select(7, [4 6], NULL, [6], {0, 314916}) = 1 (in [6], left {0, 208000})
futex(0x92c9748, FUTEX_WAIT, 2, NULL
Comment 3 Martin Høy 2005-01-18 07:25:03 EST
I can confirm (like in the 133487-report) that removing the openoffice.org-kde
package (i.e. kdefilepicker) solves the double-clicking freeze. Thus, the
problem seems to be in the filepicker itself.

But now I'm stuck with the default look of ooo... :)
Comment 4 Caolan McNamara 2005-03-14 03:47:58 EST
*** Bug 150955 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.