Bug 145322 - UDEV boot error messages after update fc2->fc3
UDEV boot error messages after update fc2->fc3
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: udev (Show other bugs)
3
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Harald Hoyer
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-01-17 09:30 EST by Joachim Backes
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-01-18 08:01:16 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
kernel-2.6.10 config file (19.92 KB, text/plain)
2005-01-18 07:51 EST, Joachim Backes
no flags Details

  None (edit)
Description Joachim Backes 2005-01-17 09:30:57 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.5)
Gecko/20041111 Firefox/1.0

Description of problem:
When booting in FC3 (Vanilla Kernel 2.6.10), getting the following
error messages:

Mounting sysfs
Creating /dev
mount: error 22 mounting tmpfs
mknod: failed to create /dev/console: 17
mknod: failed to create /dev/null: 17
Starting udev
  Welcome to Fedora Core
                Press 'I' to enter interactive startup.
Starting udev:  mount: wrong fs type, bad option, bad superblock on none,
       or too many mounted file systems
mkdir: cannot create directory `/dev//pts': File exists
mkdir: cannot create directory `/dev//shm': File exists
rm: cannot remove `/dev//.udev.tdb': Read-only file system
ln: cannot remove `/dev//fd': Read-only file system
ln: cannot remove `/dev//stdin': Read-only file system
ln: cannot remove `/dev//stdout': Read-only file system
ln: cannot remove `/dev//stderr': Read-only file system
ln: cannot remove `/dev//core': Read-only file system

Version-Release number of selected component (if applicable):
udev-039-10.FC3.6

How reproducible:
Always

Steps to Reproduce:
1.update fc2 -> fc3
2.boot
3.
    

Actual Results:  getting the above udev error messages

Expected Results:  no udev error messages

Additional info:
Comment 1 Harald Hoyer 2005-01-18 07:12:26 EST
How did you update?
see http://fedora.redhat.com/docs/udev/

The problem seems to be: "mount: error 22 mounting tmpfs" your initrd
may have a non-redhat kernel?
Comment 2 Joachim Backes 2005-01-18 07:51:54 EST
Created attachment 109922 [details]
kernel-2.6.10 config file

The attachment contains the .config of the kernel-2.6.10 I use on the system
making udev problems.
Comment 3 Joachim Backes 2005-01-18 07:53:48 EST
I updated using the FC3 CD's.
I do not use the FC3 kernel, but the Vanilla kernel 2.6.10.
Comment 4 Harald Hoyer 2005-01-18 08:01:16 EST
our initrd needs to mount a tmpfs on /dev, so this should be supported
by _your_ kernel...

Note You need to log in before you can comment on or make changes to this bug.