Bug 145354 - file doesn't tell the application name for ia64 core dumps
Summary: file doesn't tell the application name for ia64 core dumps
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: file (Show other bugs)
(Show other bugs)
Version: 3.0
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: Radek Vokal
QA Contact: Mike McLean
URL:
Whiteboard:
Keywords:
Depends On:
Blocks: 156320
TreeView+ depends on / blocked
 
Reported: 2005-01-17 18:31 UTC by Bastien Nocera
Modified: 2018-10-19 11:22 UTC (History)
2 users (show)

Fixed In Version: RHBA-2005-166
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-09-28 19:26:38 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
The patch that fix program name detection for ia64 ELF core files. (286 bytes, patch)
2005-01-21 15:51 UTC, Karel Zak
no flags Details | Diff


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2005:166 qe-ready SHIPPED_LIVE file bug fix update 2005-09-28 04:00:00 UTC

Description Bastien Nocera 2005-01-17 18:31:08 UTC
$ file core.22240
core.22240: ELF 64-bit LSB core file IA-64, version 1 (SYSV), SVR4-style

Comment 1 Radek Vokal 2005-01-19 08:28:18 UTC

*** This bug has been marked as a duplicate of 139808 ***

Comment 2 Bastien Nocera 2005-01-19 09:34:17 UTC
This bug is against RHEL3, bug 139808 is against RHEL4, reopening

Comment 3 Karel Zak 2005-01-21 15:51:05 UTC
Created attachment 110053 [details]
The patch that fix program name detection for ia64 ELF core files.

In the "file" missing definition of program name offset for the Linux
ELFCLASS64. There is defined offset for SunOS only.

Comment 4 Karel Zak 2005-01-21 15:58:24 UTC
Note: same bug is in all RHEL and FC dists.

Comment 21 Red Hat Bugzilla 2005-09-28 19:26:41 UTC
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2005-166.html



Note You need to log in before you can comment on or make changes to this bug.