Bug 145360 - sonypi module broken in kernel-2.6.10-1.741_FC3.i686.rpm
sonypi module broken in kernel-2.6.10-1.741_FC3.i686.rpm
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
3
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Dave Jones
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-01-17 14:06 EST by Richard Hart
Modified: 2015-01-04 17:15 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-02-12 23:15:53 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
/var/log/dmesg (13.18 KB, text/plain)
2005-01-17 14:11 EST, Richard Hart
no flags Details

  None (edit)
Description Richard Hart 2005-01-17 14:06:14 EST
Description of problem:
sonypi modules fails to load with following error:
# modprobe sonypi
FATAL: Error inserting sonypi
(/lib/modules/2.6.10-1.741_FC3/kernel/drivers/char/sonypi.ko): Unknown
symbol in module, or unknown parameter (see dmesg)


Version-Release number of selected component (if applicable):
kernel-2.6.10-1.741_FC3.i686.rpm

How reproducible:
always

Steps to Reproduce:
1.boot with kernel-2.6.10-1.741_FC3.i686
2.modprobe sonypi
3.
  
Actual results:
module fails

Expected results:
load module

Additional info:
Previous kernel worked fine. sonypid loaded on boot or with modprobe.
dmesg is attatched
Comment 1 Richard Hart 2005-01-17 14:11:46 EST
Created attachment 109879 [details]
/var/log/dmesg
Comment 2 Richard Hart 2005-01-17 14:39:52 EST
I did find the following line in /var/log/messages:

localhost kernel: sonypi: Unknown parameter `'
Comment 3 Dave Jones 2005-01-17 16:06:38 EST
please try the kernel at http://people.redhat.com/davej/kernels/Fedora/FC3/
Comment 4 Richard Hart 2005-01-21 17:47:00 EST
Yes the sonpi module in kernel-2.6.10-1.747_FC3.i686.rpm fixes the
problem. Now if the ipw2200 modules only worked I would use the or a
more recent kernel. Sorry to take so long to get back to you.

Note You need to log in before you can comment on or make changes to this bug.