Bug 145367 - curl barfs output on location redirects
curl barfs output on location redirects
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: curl (Show other bugs)
3.0
All Linux
medium Severity high
: ---
: ---
Assigned To: Ivana Varekova
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-01-17 14:57 EST by Jason Pyeron
Modified: 2007-11-30 17:07 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-05-12 03:00:58 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jason Pyeron 2005-01-17 14:57:22 EST
Description of problem:

curl in rhel3 barfs out location redirects.
It should be silent except for 



[root@testserver1 root]# curl --version; curl -
iL "http://www.pdinc.us/logger.jsp"
curl 7.10.6 (i386-redhat-linux-gnu) libcurl/7.10.6 OpenSSL/0.9.7a 
ipv6 zlib/1.1.4
Protocols: ftp gopher telnet dict ldap http file https ftps
Features: IPv6 SSL libz NTLM
HTTP/1.1 302 Found
Date: Mon, 17 Jan 2005 17:32:06 GMT
Server: Apache/1.3.27 (Unix)  (Red-Hat/Linux) mod_jk/1.2.0 
mod_ssl/2.8.12 OpenSSL/0.9.6b PHP/4.2.3 mo
d_perl/1.26
Location: http://www.pdinc.us:8080/logger.jsp
Transfer-Encoding: chunked
Content-Type: text/html; charset=iso-8859-1

<!DOCTYPE HTML PUBLIC "-//IETF//DTD HTML 2.0//EN">
<HTML><HEAD>
<TITLE>302 Found</TITLE>
</HEAD><BODY>
<H1>Found</H1>
The document has moved <A 
HREF="http://www.pdinc.us:8080/logger.jsp">here</A>.<P>
<HR>
<ADDRESS>Apache/1.3.27 Server at www.pdinc.us Port 80</ADDRESS>
</BODY></HTML>
HTTP/1.1 200 OK
Content-Type: text/html;charset=ISO-8859-1
Set-Cookie: JSESSIONID=4C1D7F1048123831A96EB67120CCF41D; Path=/
Content-Length: 0
Date: Mon, 17 Jan 2005 17:32:07 GMT
Server: Apache Coyote/1.0

[root@testserver1 root]#


Expected results:

[root@myserver root]# curl --version; curl -
iL "http://www.pdinc.us/logger.jsp"
curl 7.9.5 (i386-redhat-linux-gnu) libcurl 7.9.5 (OpenSSL 0.9.6b) 
(ipv6 enabled)
HTTP/1.1 302 Found
Date: Mon, 17 Jan 2005 17:29:48 GMT
Server: Apache/1.3.27 (Unix)  (Red-Hat/Linux) mod_jk/1.2.0 
mod_ssl/2.8.12 OpenSSL/0.9.6b
PHP/4.2.3 mod_perl/1.26
Location: http://www.pdinc.us:8080/logger.jsp
Transfer-Encoding: chunked
Content-Type: text/html; charset=iso-8859-1

HTTP/1.1 200 OK
Content-Type: text/html;charset=ISO-8859-1
Set-Cookie: JSESSIONID=3D19A11DA6B8FCADA0262D0FA53F9D21; Path=/
Content-Length: 0
Date: Mon, 17 Jan 2005 17:29:49 GMT
Server: Apache Coyote/1.0




-----------------------------------------
or


C:\Documents and Settings\Administrator>curl --version
curl 7.11.1 (i686-pc-cygwin) libcurl/7.11.1 OpenSSL/0.9.7e zlib/1.2.2
Protocols: ftp gopher telnet dict ldap http file https ftps
Features: SSL libz NTLM Largefile

C:\Documents and Settings\Administrator>curl -
iL "http://www.pdinc.us/logger.jsp"
HTTP/1.1 302 Found
Date: Mon, 17 Jan 2005 17:31:21 GMT
Server: Apache/1.3.27 (Unix)  (Red-Hat/Linux) mod_jk/1.2.0 
mod_ssl/2.8.12 OpenSSL/0.9.6b PHP/4.2.3 mod_perl/1.26
Location: http://www.pdinc.us:8080/logger.jsp
Transfer-Encoding: chunked
Content-Type: text/html; charset=iso-8859-1

HTTP/1.1 200 OK
Content-Type: text/html;charset=ISO-8859-1
Set-Cookie: JSESSIONID=B863401DEE1A96F97EFADBBB315A482B; Path=/
Content-Length: 0
Date: Mon, 17 Jan 2005 17:31:21 GMT
Server: Apache Coyote/1.0


C:\Documents and Settings\Administrator>
Comment 1 Ivana Varekova 2005-05-11 08:56:24 EDT
I try to reproduce your problem, but I was not succesfull. My 
curl -iL "http://www.pdinc.us/logger.jsp" output was right. I use curl 7.10.6.
Which curl relase do you use?
Ivana Varekova
Comment 2 Jason Pyeron 2005-05-11 10:53:37 EDT
new version was installed on apr 23, it also works will see when it was fixed 
then close this bug
Comment 3 Jason Pyeron 2005-05-11 10:54:22 EDT
the web server was also upgraded in between filing and now.
Comment 4 Ivana Varekova 2005-05-12 03:00:58 EDT
I can't reproduce this problem so I close this bug as CURRENTRELEASE (It could
be fixed in new version.). 
Thank you for your notice. 
If you reproduce this problem, please reopen this bug.
Ivana Varekova 

Note You need to log in before you can comment on or make changes to this bug.