Bug 145368 - kernel 2.4.10-1.741_FC3 breaks kudzu and cups
kernel 2.4.10-1.741_FC3 breaks kudzu and cups
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
3
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Dave Jones
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-01-17 15:01 EST by Oleg Makarenko
Modified: 2015-01-04 17:15 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-04-18 14:24:31 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Oleg Makarenko 2005-01-17 15:01:49 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.5)
Gecko/20041111 Firefox/1.0

Description of problem:
After kernel update to 2.4.10-1.741_FC3  kudzu hangs the machine on
system startup. Only cold boot helps. After chkconfig --del kudzu it
now hangs on cups startup.



Version-Release number of selected component (if applicable):
kernel 2.4.10-1.741_FC3

How reproducible:
Always

Steps to Reproduce:
1. Update kernel up to 2.4.10-1.741_FC3
2. reboot machine with kudzu enabled

    

Actual Results:  Machine hangs

Additional info:

I have added strace to the rc.d/kudzu script and strace output shows
that kudzu hangs in read() from /proc/bus/usb/devices

With the previous kernels (up to kernel-2.6.9-1.724_FC3) I had no
problems on my machine.

The only external usb device I have is D-Link Bluetooth DBT-120 dongle.

I have tried to remove the dongle when kudzu "sleepls" in read(). It
helps (!) and strace shows that kudzu returns from the call and
machine boots fine afterwards.

It also boots without dongle. If I plug in the dongle after the system
startup and then run 

service kudzu start

it doesn't hang.

Very strange but 100% reproducable on my machine. Looks like some
ehci/ohci modules loading and /proc reading race in the latest kernel

Btw, the motherboard is Gigagbyte K8NNXP, nForce3 chip, amd64
Comment 1 Oleg Makarenko 2005-04-18 13:49:11 EDT
Bug has disappeared with kernel-2.6.11-1.14_FC3 update

Note You need to log in before you can comment on or make changes to this bug.