Bug 145369 - slabtop does not work with new slabinfo format - "unrecognizable slabinfo version"
slabtop does not work with new slabinfo format - "unrecognizable slabinfo ver...
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: procps (Show other bugs)
3
All Linux
medium Severity low
: ---
: ---
Assigned To: Karel Zak
Brian Brock
:
: 145906 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-01-17 15:14 EST by David Hollis
Modified: 2007-11-30 17:10 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-01-24 07:12:59 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description David Hollis 2005-01-17 15:14:51 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.5)
Gecko/20041111 Firefox/1.0

Description of problem:
/usr/bin/slabtop does not work with the new /proc/slabinfo version
(2.1) provided in recent kernels (2.6.10-1.741_FC3 is what I'm
currently running).  It looks like a parse_slabinfo21() routine needs
to be created and added to proc/slab.c and appropriate entries added
to get_slabinfo() to recognize and support the new version.

Version-Release number of selected component (if applicable):
procps-3.2.3-5

How reproducible:
Always

Steps to Reproduce:
1. Run /usr/bin/slabtop
2. Get "unrecognizable slabinfo version" message
3. Goto 1 

Actual Results:  unrecognizable slabinfo version

Expected Results:  top-like display of slab info

Additional info:
Comment 1 Karel Zak 2005-01-24 02:54:41 EST
*** Bug 145906 has been marked as a duplicate of this bug. ***
Comment 2 Karel Zak 2005-01-24 07:12:59 EST
Fixed for FC3 and devel branch. 

This bug will also important for RHEL4-U? if we will release it with
kernel >=2.6.10.

Note You need to log in before you can comment on or make changes to this bug.