Bug 145378 - internal compiler seg fault
internal compiler seg fault
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: gcc (Show other bugs)
3
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jakub Jelinek
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-01-17 16:09 EST by John Farrier
Modified: 2007-11-30 17:10 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-02-21 10:58:30 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description John Farrier 2005-01-17 16:09:47 EST
Description of problem:

compiler (g++) crashes with:

cc1plus: xxxxx.cc: Input/output error
xxxxx.cc:1: internal compiler error: Segmentation fault
Please submit a full bug report,
with preprocessed source if appropriate.
See <URL:http://bugzilla.redhat.com/bugzilla> for instructions.

file opens regularly with vi.  I/O error when opening with nedit as
well, but not a seg fault.  Permissions are good and file  "appears"
to be valid.  Identical file compiles fine under RedHat 9.0.

Version-Release number of selected component (if applicable):

I believe something to be bad with the file.  I don't think an I/O
error should cause a seg fault, simply an error message and perhaps a
graceful shutdown.

No stack was avaiable to debug further on my end.
Comment 1 Jakub Jelinek 2005-01-18 08:41:10 EST
If this is a segfault caused by I/O error, we need at least:
- the .cc file in question, plus all headers it uses
- all options passed on the command line
- strace output so that we know where the I/O error happens and can try to
  simulate it using hacked up block device or something
Without at least that info, there is nothing to do about this.
Comment 2 Jakub Jelinek 2005-02-21 10:58:30 EST
If you have the requested info, please reopen.  Without that we can't fix it.

Note You need to log in before you can comment on or make changes to this bug.