Bug 145429 - Kernel oops while unloading usb-storage after reading a CD
Summary: Kernel oops while unloading usb-storage after reading a CD
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
(Show other bugs)
Version: 4
Hardware: i686 Linux
medium
medium
Target Milestone: ---
Assignee: Dave Jones
QA Contact: Brian Brock
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-01-18 11:44 UTC by vvs
Modified: 2015-01-04 22:15 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-11-04 06:39:16 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
CD track description for cdrdao (43 bytes, text/plain)
2005-01-18 11:44 UTC, vvs
no flags Details
dmesg output (13.95 KB, text/plain)
2005-01-18 11:46 UTC, vvs
no flags Details
dmesg output (17.28 KB, text/plain)
2005-07-19 10:32 UTC, vvs
no flags Details

Description vvs 2005-01-18 11:44:57 UTC
Created attachment 109920 [details]
CD track description for cdrdao

Comment 1 vvs 2005-01-18 11:44:57 UTC
Description of problem:

After reading a CD which contained bad data kernel crashed when trying to unload
scsi-mod module. This happened after I was trying to read a CD written on
Windows XP.

Version-Release number of selected component (if applicable):

kernel-2.6.10-1.741_FC3

How reproducible:

Always

Steps to Reproduce:
1. download attached foo.toc
2. dd of=foo.bin bs=150k count=0 seek=10
3. insert a blank CD-RW into USB CD writer
4. cdrdao write --device 0,0,0 --buffers 10 foo.toc
5. wait for cdrdao to finish with error
6. cdrdao read-cd --device 0,0,0 --datafile xxx.bin xxx.toc
7. wait for cdrdao to finish with read errors
8. turn off CD writer
9. modprobe -r sr-mod usb-storage
  
Actual results:

Kernel oops

Expected results:

It should unload specified modules

Additional info:

I've tried my best to reproduce that broken CD, but with the real CD kernel
oopsed with different diagnostics just after I've turned off the writer's power.
That looks very similar to recently fixed bug with pulling off USB writer's cable.

Comment 2 vvs 2005-01-18 11:46:01 UTC
Created attachment 109921 [details]
dmesg output

Comment 3 Dave Jones 2005-07-15 20:19:18 UTC
An update has been released for Fedora Core 3 (kernel-2.6.12-1.1372_FC3) which
may contain a fix for your problem.   Please update to this new kernel, and
report whether or not it fixes your problem.

If you have updated to Fedora Core 4 since this bug was opened, and the problem
still occurs with the latest updates for that release, please change the version
field of this bug to 'fc4'.

Thank you.

Comment 4 vvs 2005-07-19 10:32:41 UTC
Created attachment 116916 [details]
dmesg output

Comment 5 vvs 2005-07-19 10:34:31 UTC
It is the same with kernel-2.6.12-1.1398_FC4

Comment 6 Dave Jones 2005-09-30 06:54:00 UTC
Mass update to all FC4 bugs:

An update has been released (2.6.13-1.1526_FC4) which rebases to a new upstream
kernel (2.6.13.2). As there were ~3500 changes upstream between this and the
previous kernel, it's possible your bug has been fixed already.

Please retest with this update, and update this bug if necessary.

Thanks.


Comment 7 vvs 2005-11-04 06:39:16 UTC
fixed in kernel-2.6.13-1.1532_FC4


Note You need to log in before you can comment on or make changes to this bug.