Bug 145432 - rc.sysinit doesn't load multiple scsi_hostadapter entries from /etc/modprobe.conf
Summary: rc.sysinit doesn't load multiple scsi_hostadapter entries from /etc/modprobe....
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: initscripts   
(Show other bugs)
Version: 3
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Bill Nottingham
QA Contact: Brock Organ
URL:
Whiteboard:
Keywords:
: 154892 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-01-18 13:20 UTC by Andrew Ayres
Modified: 2014-03-17 02:51 UTC (History)
2 users (show)

Fixed In Version: RHBA-2005-124
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-01-18 19:05:48 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2005:124 normal SHIPPED_LIVE initscripts bug fix update 2005-06-09 04:00:00 UTC

Description Andrew Ayres 2005-01-18 13:20:32 UTC
Description of problem:
My computer has two scsi cards, hence in /etc/modprobe.conf I have two
scsi_hostadapter entries:

alias scsi_hostadapter aic7xxx
alias scsi_hostadapter1 aacraid

Only the first loads.

The problem is in line 177:
For module in `/sbin/modprobe -c | awk
'/^alias[[:space:]]+scsi_hostadapter[[:space:]]/ { print $3 }'` $scsi; do
        load_module $module
done

I suggest something like:
For module in `/sbin/modprobe -c | awk
'/^alias[[:space:]]+scsi_hostadapter[0-9]*[[:space:]]/ { print $3 }'`
$scsi; do
        load_module $module
done


Version-Release number of selected component (if applicable):


How reproducible:
Every time

Steps to Reproduce:
1. Have two scsi_hostadapter entries in the /etc/modprobe.conf file
2.
3.
  
Actual results:
Only first driver loaded

Expected results:
Both/all drivers to be loaded

Additional info:

Comment 1 Bill Nottingham 2005-01-18 19:05:48 UTC
aacraid *still* should get loaded from the PCI probe, FWIW.

Added in CVS, will be in 8.04-1 - thanks!

Comment 2 Bill Nottingham 2005-04-14 19:14:49 UTC
*** Bug 154892 has been marked as a duplicate of this bug. ***

Comment 3 Tim Powers 2005-06-09 12:34:14 UTC
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2005-124.html



Note You need to log in before you can comment on or make changes to this bug.