Bug 145460 - Does not build as non-root
Does not build as non-root
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: wireless-tools (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Bill Nottingham
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-01-18 13:05 EST by Enrico Scholz
Modified: 2014-03-16 22:51 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-01-18 13:16:23 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Enrico Scholz 2005-01-18 13:05:39 EST
Description of problem:

The src.rpm can not be rebuilt as an ordinary user:

| [pkgbuild@kosh rawhide]$ rpmbuild --rebuild wireless-tools-28-0.pre4.3.src.rpm
| ln -sfn libiw.so.28 /var/tmp/wireless-tools-28-0.pre4.3-root/lib/libiw.so
| *** Don't forget to add /var/tmp/wireless-tools-28-0.pre4.3-root/lib to /etc/ld.so.conf, and run ldconfig as root. ***
| /bin/sh: ldconfig: command not found
| *** Could not run ldconfig ! ***
| install -m 755 -d /var/tmp/wireless-tools-28-0.pre4.3-root/sbin
| ...
| Requires(rpmlib): rpmlib(CompressedFileNames) <= 3.0.4-1 rpmlib(PayloadFilesHavePrefix) <= 4.0-1
|     File not found by glob: /var/tmp/wireless-tools-28-0.pre4.3-root/usr/lib/*.so

Adding /sbin to $PATH does not help:

| [pkgbuild@kosh rawhide]$ PATH=$PATH:/sbin rpmbuild --rebuild wireless-tools-28-0.pre4.3.src.rpm
| ...
| ln -sfn libiw.so.28 /var/tmp/wireless-tools-28-0.pre4.3-root/lib/libiw.so
| *** Don't forget to add /var/tmp/wireless-tools-28-0.pre4.3-root/lib to /etc/ld.so.conf, and run ldconfig as root. ***
| ldconfig: Can't create temporary cache file /etc/ld.so.cache~: Permission denied
| *** Could not run ldconfig ! ***
| install -m 755 -d /var/tmp/wireless-tools-28-0.pre4.3-root/sbin
| ...
| Requires(rpmlib): rpmlib(CompressedFileNames) <= 3.0.4-1 rpmlib(PayloadFilesHavePrefix) <= 4.0-1
|     File not found by glob: /var/tmp/wireless-tools-28-0.pre4.3-root/usr/lib/*.so



Version-Release number of selected component (if applicable):

wireless-tools-28-0.pre4.3
Comment 1 Enrico Scholz 2005-01-18 13:16:23 EST
sorry... was caused by the bad globbing of old rpm with new glibc.

Note You need to log in before you can comment on or make changes to this bug.