Bug 145466 - UPDATE: ImageMagick-6.2.0
Summary: UPDATE: ImageMagick-6.2.0
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: ImageMagick   
(Show other bugs)
Version: rawhide
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Matthias Clasen
QA Contact:
URL:
Whiteboard:
Keywords: FutureFeature
: 141991 147734 (view as bug list)
Depends On: 113951
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-01-18 19:15 UTC by Rex Dieter
Modified: 2007-11-30 22:10 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-04-26 04:58:32 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
ImageMagick-6.1.8.8 specfile (17.77 KB, text/plain)
2005-01-18 19:30 UTC, Rex Dieter
no flags Details
local_doc patch (1.41 KB, patch)
2005-01-18 19:31 UTC, Rex Dieter
no flags Details | Diff
pkgconfig patch (474 bytes, patch)
2005-01-18 19:32 UTC, Rex Dieter
no flags Details | Diff
ImageMagick-6.1.9.3 specfile (19.29 KB, text/plain)
2005-01-26 19:45 UTC, Rex Dieter
no flags Details
ImageMagick-6.2.0.6-1 specfile (18.54 KB, text/plain)
2005-03-09 21:31 UTC, Rex Dieter
no flags Details
ImageMagick-6.2.0.6-1 specfile take #2 (18.49 KB, text/plain)
2005-03-09 21:39 UTC, Rex Dieter
no flags Details

Description Rex Dieter 2005-01-18 19:15:23 UTC
 

Comment 1 Rex Dieter 2005-01-18 19:30:18 UTC
Created attachment 109941 [details]
ImageMagick-6.1.8.8 specfile

Suggested specfile for ImageMagick-6.1.8.8 update.  Includes patches from bug
#113951 (--with-gslib support) and bug #145449 (libtool/pkgconfig cleanup).

Includes bits for including support from pkgs currently in Extras (jasper,
lcms, graphviz).

Cleaned out unused/extraneous bits

Comment 2 Rex Dieter 2005-01-18 19:31:08 UTC
Created attachment 109942 [details]
local_doc patch

Comment 3 Rex Dieter 2005-01-18 19:32:08 UTC
Created attachment 109943 [details]
pkgconfig patch

See also bug #145449

Comment 4 Paul Bolle 2005-01-21 22:29:31 UTC
For what it's worth: the specfile (of comment 1) also works for
release 6.1.9-2 (current beta), using the three attched/linked to
patches (ImageMagick-6.1.8-local_doc.patch,
ImageMagick-5.5.7-libgs.patch, ImageMagick-6.1.8-pkgconfig.patch).

Works here meaning: ImageMagick-6.1.9.2-1.i386.rpm and friends
(*devel*, *perl*, *c++* and *c++-devel*) build without problems.

Comment 5 Rex Dieter 2005-01-26 19:43:34 UTC
Verified ImageMagick-6.1.9.3 build success.

Comment 6 Rex Dieter 2005-01-26 19:45:36 UTC
Created attachment 110266 [details]
ImageMagick-6.1.9.3 specfile

Comment 7 Matthias Clasen 2005-03-09 19:26:41 UTC
*** Bug 141991 has been marked as a duplicate of this bug. ***

Comment 8 Matthias Clasen 2005-03-09 19:26:51 UTC
*** Bug 147734 has been marked as a duplicate of this bug. ***

Comment 9 Rex Dieter 2005-03-09 21:31:09 UTC
Created attachment 111823 [details]
ImageMagick-6.2.0.6-1 specfile

* Wed Mar 09 2005 Rex Dieter 6.2.0.6-1
- 6.2.0.6 (#145446)
- additional cleanups/hints (#141991)
- use %%_datadir/ImageMagick-%%VER (like upstream)
- purge/cleanup Reqs (purge libtool archives/pkgconfig) (#145449)
- Core: --with-gslib (ghostscript, #113951)
- Core: --with-wmf (libwmf)
- Extras: --with-jp2 (jasper) 
- Extras: --with-lcms (lcms)
- Extras: --with-dot (graphviz)

Comment 10 Rex Dieter 2005-03-09 21:39:10 UTC
Created attachment 111824 [details]
ImageMagick-6.2.0.6-1 specfile take #2

removed some extraneous comments, actually use %{perl_prefix}.	

Note: includes some legacy bits allowing build all the way back to rh73
(program_prefix, perl_ver, perl_prefix), which can probably be omitted when/if
incorporating into Core.

Comment 11 Matthias Clasen 2005-03-19 03:07:56 UTC
6.2.0 is in testing now. I'll keep this open to check the configure flags you
propose.

Comment 12 Matthias Clasen 2005-04-26 04:58:32 UTC
I've incorporated most of your improvements into 6.2.1.7-3 which is in Rawhide now.


Note You need to log in before you can comment on or make changes to this bug.