Bug 145490 - gzip -l outputs negative number on zipped files over 2GB
Summary: gzip -l outputs negative number on zipped files over 2GB
Status: CLOSED DUPLICATE of bug 116967
Alias: None
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: gzip   
(Show other bugs)
Version: 3.0
Hardware: x86_64
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Tomas Mraz
QA Contact: Ben Levenson
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-01-18 22:10 UTC by Need Real Name
Modified: 2007-11-30 22:07 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-03-22 13:47:13 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Need Real Name 2005-01-18 22:10:01 UTC
Description of problem:
gzip -l outputs negative number on zipped files over 2GB

18:root@rndquad streams > gzip -l 
./T26Z4_stream/t26z41_20A42_dieopc.sf.gz
         compressed        uncompressed  ratio uncompressed_name
         2891078956          2042861568 -41.5%
./T26Z4_stream/t26z41_20A42_dieopc.sf

Version-Release number of selected component (if applicable):
gzip 1.3.3
/bin/gzip: ELF 64-bit LSB executable, AMD x86-64, version 1 (SYSV),
for GNU/Linux 2.4.0, dynamically linked (uses shared libs), stripped

How reproducible:
gzip -l on file over 2GB

Steps to Reproduce:
1.gzip -l on file over 2GB
2.
3.
  
Actual results:

gzip -l  /tmp/t26z41_20A42_dieopc.sf.gz
         compressed        uncompressed  ratio uncompressed_name
         2891078956          2042861568 -41.5% /tmp/t26z41_20A42_dieopc.sf

Expected results:
 gzip -l  /tmp/t26z41_20A42_dieopc.sf.gz
         compressed        uncompressed  ratio uncompressed_name
         2891078956          10632796160 72.8% /tmp/t26z41_20A42_dieopc.sf

Additional info:

Comment 1 Tomas Mraz 2005-03-22 13:47:13 UTC

*** This bug has been marked as a duplicate of 116967 ***


Note You need to log in before you can comment on or make changes to this bug.