Bug 145494 - Membership in too many groups prevents login ("getgroups: Invalid argument")
Summary: Membership in too many groups prevents login ("getgroups: Invalid argument")
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: openssh   
(Show other bugs)
Version: 2
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: Tomas Mraz
QA Contact: Brian Brock
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-01-18 22:25 UTC by Kenneth Porter
Modified: 2007-11-30 22:10 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-01-31 21:19:28 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Kenneth Porter 2005-01-18 22:25:06 UTC
I edited /etc/group to add myself to another group, raising my total
to 33, and I was no longer able to log in. /var/log/secure reported
"fatal: getgroups: Invalid argument". Some googling revealed the
source of the problem, that getgroups returns EINVAL when the number
of groups exceeds a kernel limit (NGROUPS_MAX in
/usr/include/linux/limits.h).

I'm not sure what the best fix is, but one shouldn't be locked out of
logging in when another group is added to one's list. sshd should fail
in a more graceful way, for example allowing the login but without all
supplmentary groups available, and a warning issued to the login
terminal and the syslog.

See also bug 145492.

Comment 1 Tomas Mraz 2005-01-31 21:19:28 UTC
It seems to be working fine in FC3.


Note You need to log in before you can comment on or make changes to this bug.