Bug 145519 - cannot resolve hostnames after update to version 0.3.3-1.cvs20050112.1.fc3
cannot resolve hostnames after update to version 0.3.3-1.cvs20050112.1.fc3
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: NetworkManager (Show other bugs)
3
i686 Linux
medium Severity high
: ---
: ---
Assigned To: Dan Williams
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-01-19 04:14 EST by Pawel Orzechowski
Modified: 2007-11-30 17:10 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-05-16 16:04:01 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
output of /var/log/messages (2.29 KB, text/plain)
2005-01-19 04:18 EST, Pawel Orzechowski
no flags Details
content of /etc/resolv.conf (128 bytes, text/plain)
2005-01-19 04:20 EST, Pawel Orzechowski
no flags Details
attachement with contents of /var/log/messages and /etc/resolv.conf (8.35 KB, text/plain)
2005-01-27 17:30 EST, Pawel Orzechowski
no flags Details

  None (edit)
Description Pawel Orzechowski 2005-01-19 04:14:03 EST
Description of problem: 
After update to version 0.3.3-1.cvs20050112.1.fc3 of NetworkManager 
I cannot resolve any hostname. After start of network manager it 
replaces /etc/resolv.conf with its own version which points to to 
local named daemon. Problem is that named cannot find forwarders. I 
have attached output from /var/log/messages. Previous version worked 
ok. 
 
 
Version-Release number of selected component (if applicable): 
 
 
How reproducible: 
 
 
Steps to Reproduce: 
1.start NetworkManager  
2.nslookup hostname 
3.stop NetworkManager 
   
Actual results: 
host <hostname> 
; connection timed out; no servers could be reached 
 
Expected results: 
host <hostname> 
hostname is <ip> 
 
 
Additional info: 
Moreover, after stopping of NetworkManager it does not restore last 
version of resolv.conf file.
Comment 1 Pawel Orzechowski 2005-01-19 04:18:27 EST
Created attachment 109960 [details]
output of /var/log/messages

This is output form /var/log/messages while starting and stoppping
NetworkManager
Comment 2 Pawel Orzechowski 2005-01-19 04:20:52 EST
Created attachment 109961 [details]
content of /etc/resolv.conf 

this is /etc/resolv.conf file after stopping of NetworkManager
Comment 3 drago01 2005-01-22 03:21:24 EST
I have the same problem here....
Comment 4 Pawel Orzechowski 2005-01-26 17:36:07 EST
After upgrade to NetworkManager-0.3.3-1.cvs20050119.2.fc3 the 
situation is partialy resolved: only fully qualified hostnames can 
be resolved. This is because now NetworkManager removes "search" 
option from /etc/resolv.conf. When network services are started 
without starting NetworkManager file /etc/resolv.conf contains 
"nameserver" option as well as "search" option. After start of 
network manager "search option" is being removed. 
Comment 5 Pawel Orzechowski 2005-01-27 13:21:16 EST
After further investigation it occured that my previous post does 
not describe the problem correctly:-(.   
After reboot of the system, during network services start, ip 
address is acquired through dhcp client. Also 
suitable /etc/resolv.conf file is generated: 
; generated by /sbin/dhclient-script 
search orzeszkowej.gdynia.mpsz.pl 
nameserver 10.47.0.1 
Then when I start NetworkManager, file /etc/resolv.conf is changed 
to: 
; generated by NetworkManager, do not edit! 
(yes, it has only one line!!!) 
Stopping NetworkManager does not correct the problem, restart of 
network services is needed. 
 
 
 
Comment 6 Dan Williams 2005-01-27 14:51:26 EST
Can you post the debug output in /var/log/messages where the DHCP
server replies with the DHCP data?

Thanks,
Dan
Comment 7 Pawel Orzechowski 2005-01-27 17:30:15 EST
Created attachment 110329 [details]
attachement with contents of /var/log/messages and /etc/resolv.conf
Comment 8 Pawel Orzechowski 2005-01-27 17:31:09 EST
Hi Dan, 
I have created an attachement with six sections: 
1. contents of /var/log/messages after command "service network 
start" has been issued 
2. contents of /etc/resolv.conf after command "service network 
start" has been issued 
3. contents of /var/log/messages after command "service 
NetworkManager start" has been issued 
4. contents of /etc/resolv.conf after command "service 
NetworkManager start" has been issued 
5. contents of /var/log/messages after ethernet cable was unplugged 
and plugged again 
6. contents of /etc/resolv.conf after ethernet cable was unplugged 
and plugged again 
 
Some messages are in Polish and if it is a problem please let me 
know and I will change system locales. I hope it helps 
Pawel 
Comment 9 Dan Williams 2005-01-29 18:00:23 EST
This bug has been fixed in CVS (the one with wired networks), I'm not
sure if it made it to the latest FC3 update though.  I'll be pushing
another FC3 update soon however.
Comment 10 Pawel Orzechowski 2005-02-06 15:03:52 EST
Hi Dan, 
 
I've prepared package which is based on the 20050202 NetworkManager 
version and it seems to work ok now.  
 
Regards 
 
Pawel 
 
PS. There were some problems running autoconf.sh --prefix=/usr 
--sysconfdir=/etc:  
- it required gnome-common package for 
running /usr/bin/gnome-autogen.sh 
- it required libtoolize before running ./autogen.sh otherwise it 
finished with an error "config.status: error: cannot find input 
file: Makefile.in " 
 
 
Comment 11 Dan Williams 2005-05-16 16:04:01 EDT
closing since its fixed...
Comment 12 drago01 2005-05-17 02:20:58 EDT
where is it fixed?
It still happens on an updated FC3 box:
NetworkManager-0.3.4-1.1.0.fc3

Note You need to log in before you can comment on or make changes to this bug.