This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 145565 - pbmtext crashes
pbmtext crashes
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: netpbm (Show other bugs)
3
x86_64 Linux
medium Severity high
: ---
: ---
Assigned To: Jindrich Novy
Ben Levenson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-01-19 14:39 EST by Boris Goldowsky
Modified: 2013-07-02 19:05 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-01-20 06:48:00 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Boris Goldowsky 2005-01-19 14:39:16 EST
Description of problem:

Program pbmtext crashes, and can't be run under gdb:

$ pbmtext "hello"
P4
51 29
Segmentation fault
in /var/log/messages: 
Jan 19 14:36:11 ant kernel: pbmtext[5205]: segfault at
0000000000000000 rip 0000003174c0b2a3 rsp 0000007fbfffe050 error 4

$ gdb /usr/bin/pbmtext

(gdb) run 'hello'
Starting program: /usr/bin/pbmtext 'hello'
warning: Child process unexpectedly missing: No child processes

Program terminated with signal ?, Unknown signal.
The program no longer exists.

Version-Release number of selected component (if applicable):

netpbm-progs-10.25-2
netpbm-10.25-2
netpbm-debuginfo-10.25-2

How reproducible:

always
Comment 1 Jindrich Novy 2005-01-20 06:48:00 EST
Please try the latest development netpbm-10.26-1 release. Some fixes
were made to pbmtext in upstream because pbmtext segfaulted for any
character >127. Also your issue is fixed by it.

Note You need to log in before you can comment on or make changes to this bug.