Bug 145580 - Can't run GUI apps with gcj4
Can't run GUI apps with gcj4
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: gcc4 (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jakub Jelinek
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-01-19 16:26 EST by Anthony Green
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version: 4.0.0-0.30
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-03-01 07:27:43 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Anthony Green 2005-01-19 16:26:11 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.5)
Gecko/20041111 Firefox/1.0

Description of problem:
GCC4 includes this library:

/usr/lib/lib-gnu-java-awt-peer-gtk_fc4.so.6.0.0

This library name confuses libgcj_fc4's library lookup mechanism.
When searching for gnu.java.awt.peer.gtk, it will load GCC 3.4's
lib-gnu-java-awt-peer-gtk.so instead.

Version-Release number of selected component (if applicable):
libgcj4-4.0.0-0.18

How reproducible:
Always

Steps to Reproduce:
1.Try to run a GUI app with gij4.
2
3.
    

Additional info:

We don't know how to fix yet.  Here are some suggestions from IRC.

green ok.  isn't that library name, above, a problem?
green since it doesn't map to gcj's magic naming scheme.
tromey yes
tromey good point
green so, my gij4 is probably picking up the GCC 3.4's version.
tromey yeah
green ok - that's  a problem!
tromey yes, a packaging bug
green Why don't we just link that library to libgcj_fc4.so
tromey we didn't think of this when we were talking about the soname stuff
tromey not everybody wants the peers pulled in
tromey that's all I can think of
green What other solution works?
green We can change the peer class name for gcj4
green gross
tromey we can change the soname instead of adding _fc4
tromey though, maybe that means other problems
tromey ugh
tromey we could look in a versionned directory instead
tromey and not /usr/lib
Comment 1 Jakub Jelinek 2005-01-19 16:42:06 EST
Well, either we can teach it to try first lib*_fc4.so.N before lib*.so.N
before lib*.so, or we can teach it to look into /usr/lib/gcj/4.0.0/$LIB/
or something like that first.  Guess about the same amount of work.
Comment 2 Jakub Jelinek 2005-03-01 07:27:43 EST
I guess this problem should be history now that gcc-4.0.0-0.30 subpackages in
rawhide include libgcj.so.6 etc., not libgcj_fc4.so.6 and so on.

Note You need to log in before you can comment on or make changes to this bug.