Bug 14563 - mouseconfig doesn't autoselect emulate 3 buttons for 2 button mice
mouseconfig doesn't autoselect emulate 3 buttons for 2 button mice
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: mouseconfig (Show other bugs)
7.1
i386 Linux
high Severity medium
: ---
: ---
Assigned To: Trond Eivind Glomsrxd
Winston rc1
:
: 13076 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-07-24 17:44 EDT by Hans de Goede
Modified: 2008-05-01 11:37 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-08-06 19:27:16 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Hans de Goede 2000-07-24 17:44:08 EDT
mouseconfig doesn't autoselect emulate 3 buttons for 2 button mice, like
anaconda in graphical mode does, so this is sorta inconsistent (afaik
textmode install uses mouseconfig to setup the mouse, if it just looks
the same, then this needs to be entered against text-anaconda too)
Comment 1 David Lawrence 2000-07-25 12:32:49 EDT
Confirmed that also when using mouseconfig post-install from the command line,
the --emulthree option causes no change in the Emulate Three Buttons check box.
Normal behaviour would be to check the box automatically if this option is
given. This may be related to this other issue.
Comment 2 Glen Foster 2000-07-30 15:55:05 EDT
This defect is considered MUST-FIX for Winston Release-Candidate #1
Comment 3 Glen Foster 2000-08-03 17:21:33 EDT
Does this problem still exist in Pinstripe?
Comment 4 Trond Eivind Glomsrxd 2000-08-04 11:16:55 EDT
I'll fix this.
Comment 5 Trond Eivind Glomsrxd 2000-08-06 19:27:14 EDT
*** Bug 13076 has been marked as a duplicate of this bug. ***
Comment 6 Trond Eivind Glomsrxd 2000-08-06 19:31:09 EDT
The --emulthree option was for kickstart....

Anyway, mouseconfig now respects it for interactive mode as well.
Comment 7 Hans de Goede 2000-08-11 18:15:16 EDT
Hmm this doesn't work for me with RC1, reopen.

I have 2 problems now:
-with autoselect 3 buttons I mean in interactive mode change mousetype from
Generic PS2 to Generic PS2 3 buttons and then the emu 3 button automagilcy
toggles of. So this changes whne I do arrow up / down through the list. I did
notice that it does select the right initial value for it depending on the
current mouse.
- --emulthree seems to be ginored in interactive mode (overridden by the above
  auto initial value ?!)

Reopen ?!
Comment 8 Hans de Goede 2000-08-21 05:58:50 EDT
Ehm when I said reopen?! I didn't actual reopen it leaving that call to you, but
some kinda reaction like this will / won't be fixed an reopening the bug if you
plan on fixing it would be nice.

Note You need to log in before you can comment on or make changes to this bug.