Bug 1456463 - hp-check shows 'CUPS incompatible or not running' even if CUPS is running
Summary: hp-check shows 'CUPS incompatible or not running' even if CUPS is running
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: hplip
Version: 7.4
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: rc
: ---
Assignee: Zdenek Dohnal
QA Contact: qe-baseos-daemons
URL:
Whiteboard:
Depends On:
Blocks: 1456467
TreeView+ depends on / blocked
 
Reported: 2017-05-29 12:50 UTC by Zdenek Dohnal
Modified: 2019-11-22 08:33 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
: 1456467 (view as bug list)
Environment:
Last Closed: 2019-11-22 08:33:49 UTC
Target Upstream Version:


Attachments (Terms of Use)
Proposed patch (1.62 KB, patch)
2017-05-30 09:57 UTC, Zdenek Dohnal
no flags Details | Diff
Proposed patch with lpstat -r (2.10 KB, patch)
2017-12-07 14:40 UTC, Zdenek Dohnal
no flags Details | Diff

Description Zdenek Dohnal 2017-05-29 12:50:51 UTC
Description of problem:
When hp-check is run, output says 'CUPS incompatible or not running', even if CUPS is running. This is caused by using 'cups-config --version' command in check.py script. This cups-config command is in cups-devel package, which isn't installed with main package.
This hp-check message is misleading and it should be corrected.

Version-Release number of selected component (if applicable):
cups-1.6.3-26

How reproducible:
Always, when cups-devel isn't installed

Steps to Reproduce:
1. install hplip-gui
2. $ hp-check
3.

Actual results:
Message about 'CUPS incompatible or not running'

Expected results:
If CUPS is installed, it should show version and OK

Additional info:

Comment 2 Zdenek Dohnal 2017-05-30 09:57:25 UTC
Created attachment 1283383 [details]
Proposed patch

Comment 7 Zdenek Dohnal 2017-12-07 14:40:24 UTC
Created attachment 1364337 [details]
Proposed patch with lpstat -r

Comment 8 Boyd 2018-06-29 12:04:44 UTC
Same problem exists on  Fedora 28/29.   In addition hp-check also reports:

error: python3-notify2 Python libnotify - Python bindings for the libnotify Desktop notifications OPTIONAL        -               -               MISSING    'python3-notify2 needs to be installed

This package doesn't seem to exist.

Comment 9 sean darcy 2019-04-11 17:02:39 UTC
Same here:

fc29

hp-check -t

HP Linux Imaging and Printing System (ver. 3.18.12)
Dependency/Version Check Utility ver. 15.1
.........
------------------------
| External Dependencies |
-------------------------

 error: cups          CUPS - Common Unix Printing System                           REQUIRED        1.1             -               INCOMPAT   'CUPS may not be installed or not running'
............

| INSTALLED CUPS PRINTER QUEUES |
---------------------------------

 
HP_LaserJet_Pro_M148f-M149f
---------------------------
Type: Printer
Device URI: hp:/net/HP_LaserJet_Pro_M148f-M149f?ip=10.10.11.155
PPD: /etc/cups/ppd/HP_LaserJet_Pro_M148f-M149f.ppd
PPD Description: HP LaserJet Pro M148f-M149f Postscript (recommended)
Printer status: printer HP_LaserJet_Pro_M148f-M149f is idle.  enabled since Thu 04 Apr 2019 11:32:08 AM EDT
error: Unable to communicate with device (code=12): hp:/net/HP_LaserJet_Pro_M148f-M149f?ip=10.10.11.155
error: unable to open channel
error: Communication status: Failed


Of course, cups is enabled and is running.

● cups.service - CUPS Scheduler
   Loaded: loaded (/usr/lib/systemd/system/cups.service; enabled; vendor preset: disabled)
   Active: active (running) since Thu 2019-04-11 12:40:10 EDT; 18min ago
     Docs: man:cupsd(8)
 Main PID: 19030 (cupsd)
   Status: "Scheduler is running..."
    Tasks: 1 (limit: 4915)
   Memory: 8.9M
   CGroup: /system.slice/cups.service
           └─19030 /usr/sbin/cupsd -l

Comment 10 Zdenek Dohnal 2019-11-22 08:33:49 UTC
Thank you for taking the time to report this issue to us. We appreciate the feedback and use reports such as this one to guide our efforts at improving our products. That being said, this bug tracking system is not a mechanism for requesting support, and we are not able to guarantee the timeliness or suitability of a resolution.

If this issue is critical or in any way time sensitive, please raise a ticket through the regular Red Hat support channels to ensure it receives the proper attention and prioritization to assure a timely resolution. 

For information on how to contact the Red Hat production support team, please visit:
    https://www.redhat.com/support/process/production/#howto

The issue is not critical to hplip functionality - those dependency checks are mostly for build dependencies (even if --runtime option is used).


Note You need to log in before you can comment on or make changes to this bug.