Bug 145677 - Badness in ipi_handler at drivers/char/agp/generic.c
Badness in ipi_handler at drivers/char/agp/generic.c
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: kernel (Show other bugs)
4.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Dave Jones
Brian Brock
:
: 145788 149052 (view as bug list)
Depends On:
Blocks: 144195
  Show dependency treegraph
 
Reported: 2005-01-20 11:37 EST by Pascal de Bruijn
Modified: 2015-01-04 17:15 EST (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-02-24 00:20:48 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Pascal de Bruijn 2005-01-20 11:37:06 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.5) Gecko/20041107 Firefox/1.0

Description of problem:
After upgrading the kernel from '2.6.9-1.675 ELsmp' to '2.6.9-5 ELsmp', my agpgart begun giving errors.


Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Turn on machine
2. Boot the kernel
3. Watch the dmesg
  

Actual Results:  The agpgart errors.

Expected Results:  The agpgart should load without any issues.

Additional info:


-----------------------------------------------------------------------------
Linux agpgart interface v0.100 (c) Dave Jones
agpgart: Detected an Intel 440LX Chipset.
agpgart: Maximum main memory to use for agp memory: 439M
Badness in ipi_handler at drivers/char/agp/generic.c:987
 [<c0204280>] ipi_handler+0x42/0x59
 [<c0115b57>] smp_call_function_interrupt+0x3a/0x77
 [<c02c6cc2>] call_function_interrupt+0x1a/0x20
 [<c0104018>] default_idle+0x0/0x2c
 [<c0104041>] default_idle+0x29/0x2c
 [<c010409d>] cpu_idle+0x26/0x3b
agpgart: AGP aperture is 8M @ 0xe7800000
-----------------------------------------------------------------------------
Comment 1 Len Brown 2005-01-25 01:38:02 EST
I too see this with 2.6.9-5.ELsmp -- on a D875PBZ: 
--- 
Linux agpgart interface v0.100 (c) Dave Jones 
agpgart: Detected an Intel i875 Chipset. 
agpgart: Maximum main memory to use for agp memory: 940M 
Badness in ipi_handler at drivers/char/agp/generic.c:987 
 [<c0204280>] ipi_handler+0x42/0x59 
 [<c0115b57>] smp_call_function_interrupt+0x3a/0x77 
 [<c02c6cc2>] call_function_interrupt+0x1a/0x20 
 [<c0104018>] default_idle+0x0/0x2c 
 [<c0104041>] default_idle+0x29/0x2c 
 [<c010409d>] cpu_idle+0x26/0x3b 
agpgart: AGP aperture is 64M @ 0xf8000000 
 
Comment 2 Len Brown 2005-01-25 01:43:24 EST
oops goes away if SMP kernel is booted with "maxcpus=1" 
Comment 3 Dave Jones 2005-01-25 01:43:59 EST
*** Bug 145788 has been marked as a duplicate of this bug. ***
Comment 4 Dave Jones 2005-01-25 01:45:50 EST
this was added as a (bad) workaround for pci posting bugs.
Since then, the correct fixes went into upstream, so this bad patch should be
dropped, and replaced with something that actually works.
Comment 6 Jay Turner 2005-02-18 05:12:17 EST
*** Bug 149052 has been marked as a duplicate of this bug. ***
Comment 7 Dave Jones 2005-02-24 00:20:48 EST
fixed in the latest errata kernel.

Note You need to log in before you can comment on or make changes to this bug.