Bug 145700 - sound not working with ali5451 on fc3 with kernels 2.6.10
sound not working with ali5451 on fc3 with kernels 2.6.10
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
3
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Dave Jones
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-01-20 13:24 EST by Andrea Chiavazza
Modified: 2015-01-04 17:15 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-02-07 14:02:33 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Andrea Chiavazza 2005-01-20 13:24:21 EST
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1)

Description of problem:
sound card ali5451 is detected and mixers controls work but sound is 
just not coming aout of speakers.
This happens on last two 2.6.10 released kernels updates but not with 
previous 2.6.9 kernels.
pci=routeirq didn´t help.


Version-Release number of selected component (if applicable):
kernel-2.6.10-1.741

How reproducible:
Always

Steps to Reproduce:
1.boot a 2.6.10 kernel instead of a 2.6.9
2.
3.
    

Actual Results:  sound didn´t work

Expected Results:  sound should work

Additional info:

machine is a laptop medion md40888 www.medion.co.uk
Comment 1 Andrea Chiavazza 2005-01-31 16:36:39 EST
sound is still broken in the latest testing kernel.
To summarize:

WORKING
kernel-2.6.9-1.681_FC3.i686
kernel-2.6.9-1.724_FC3.i686

NOT WORKING
kernel-2.6.10-1.737_FC3.i686
kernel-2.6.10-1.753_FC3.i686
kernel-2.6.10-1.741_FC3.i686
Comment 2 Andrea Chiavazza 2005-02-07 14:00:39 EST
Looks like there is a way to fix sound on the kernels marked above 
as "not working" as it´s been reported on the net by someone.
The fix consists in muting "headphone jack sense" "line jack sense" 
mixers setting via any mixer setting programs like "volume 
control", "alsa mixer" and similar.
Theese setting were apparently introduced in 2.6.10 and are meant to 
mute speakers when headphones or line-in jacks are plugged in.
I'm still not convinced that the actual behaviour is normal but I´m 
going to close this bug anyway becouse the sound IS working after 
all. Someone that understand well how theese "jack sense" things are 
supposed to behave will possibly report a new bug on the issue.

Note You need to log in before you can comment on or make changes to this bug.