This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 145778 - Evolution hangs after selecting timezone in guided setup
Evolution hangs after selecting timezone in guided setup
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: evolution (Show other bugs)
rawhide
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Dave Malcolm
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-01-21 10:22 EST by James Laska
Modified: 2013-09-02 02:04 EDT (History)
2 users (show)

See Also:
Fixed In Version: gtk 2.6.2
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-08-18 00:32:14 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description James Laska 2005-01-21 10:22:58 EST
# evolution-2.0.3-2.i386

After a fresh install of rawhide-20050120 ... I launched evolution.  After
following through the guided wizard prompts, the application appears to hang
after selecting the timezone.  I have entered my imap server for send+receive
which resulted in a hang, and I have also selected no incoming server and
sendmail as the sender.  

An strace -f of the process can be found at the url below:

   http://people.redhat.com/jlaska/evolution.strace

I have also installed many debuginfo packages and have run taken a backtrace
when the hang occurs.  Please advise if there are additional debugging steps
you'd like to see.

0x004d6b9d in memset () from /lib/tls/libc.so.6
(gdb) bt
#0  0x004d6b9d in memset () from /lib/tls/libc.so.6
#1  0xbfe31650 in ?? ()
#2  0x00756260 in IA__g_value_unset (value=0xbfe316d4) at string3.h:91
#3  0x0074ac0b in IA__g_signal_emit_valist (instance=0x90a7758,
signal_id=3219330772, detail=0,
    var_args=0xbfe31854 "\uffff\024\uffff\b|d\222") at gsignal.c:2273
#4  0x0074af24 in IA__g_signal_emit (instance=0x0, signal_id=0, detail=0) at
gsignal.c:2288
#5  0x00a8faca in IA__gtk_widget_child_focus (widget=0x90a7758,
direction=GTK_DIR_TAB_FORWARD) at gtkwidget.c:5456
#6  0x00926ac4 in gtk_container_focus (widget=0x925f3d8,
direction=GTK_DIR_TAB_FORWARD) at gtkcontainer.c:2030
#7  0x009ab00f in _gtk_marshal_BOOLEAN__ENUM (closure=0x8f7fe68,
return_value=0xbfe31a10, n_param_values=2,
    param_values=0xbfe31b70, invocation_hint=0xbfe31a38, marshal_data=0x926977)
at gtkmarshalers.c:163
#8  0x007360dd in g_type_class_meta_marshal (closure=0x8f7fe68,
return_value=0x0, n_param_values=0,
    param_values=0xbfe31b70, invocation_hint=0x0, marshal_data=0x0) at
gclosure.c:514
#9  0x00735e48 in IA__g_closure_invoke (closure=0x8f7fe68, return_value=0x0,
n_param_values=0, param_values=0x0,
    invocation_hint=0x0) at gclosure.c:437
#10 0x00749773 in signal_emit_unlocked_R (node=0x8f7fec0, detail=0,
instance=0x925f3d8, emission_return=0xbfe31b00,
    instance_and_params=0xbfe31b70) at gsignal.c:2523
#11 0x0074a9af in IA__g_signal_emit_valist (instance=0x925f3d8, signal_id=0,
detail=0,
    var_args=0xbfe31d00 "\f\035\uffff\uffff\uffff\024\uffff\b|d\222") at
gsignal.c:2254
#12 0x0074af24 in IA__g_signal_emit (instance=0x0, signal_id=0, detail=0) at
gsignal.c:2288
#13 0x00a8faca in IA__gtk_widget_child_focus (widget=0x925f3d8,
direction=GTK_DIR_TAB_FORWARD) at gtkwidget.c:5456
#14 0x00926ac4 in gtk_container_focus (widget=0x91c4e68,
direction=GTK_DIR_TAB_FORWARD) at gtkcontainer.c:2030
#15 0x009ab00f in _gtk_marshal_BOOLEAN__ENUM (closure=0x8f7fe68,
return_value=0xbfe31ec0, n_param_values=2,
    param_values=0xbfe32020, invocation_hint=0xbfe31ee8, marshal_data=0x926977)
at gtkmarshalers.c:163
#16 0x007360dd in g_type_class_meta_marshal (closure=0x8f7fe68,
return_value=0x0, n_param_values=0,
    param_values=0xbfe32020, invocation_hint=0x0, marshal_data=0x0) at
gclosure.c:514
#17 0x00735e48 in IA__g_closure_invoke (closure=0x8f7fe68, return_value=0x0,
n_param_values=0, param_values=0x0,
    invocation_hint=0x0) at gclosure.c:437
#18 0x00749773 in signal_emit_unlocked_R (node=0x8f7fec0, detail=0,
instance=0x91c4e68, emission_return=0xbfe31fb0,
    instance_and_params=0xbfe32020) at gsignal.c:2523
#19 0x0074a9af in IA__g_signal_emit_valist (instance=0x91c4e68, signal_id=0,
detail=0,
    var_args=0xbfe321b0
"\uffff!\u3ff0$\uffff\uffff\uffff!\uffff\uffff&\uffff\uffff") at gsignal.c:2254
#20 0x0074af24 in IA__g_signal_emit (instance=0x0, signal_id=0, detail=0) at
gsignal.c:2288
#21 0x00a8faca in IA__gtk_widget_child_focus (widget=0x91c4e68,
direction=GTK_DIR_TAB_FORWARD) at gtkwidget.c:5456
#22 0x00a9c929 in gtk_window_focus (widget=0x925f2a0,
direction=GTK_DIR_TAB_FORWARD) at gtkwindow.c:4652
#23 0x009ab00f in _gtk_marshal_BOOLEAN__ENUM (closure=0x8f7fe68,
return_value=0xbfe32350, n_param_values=2,
    param_values=0xbfe324b0, invocation_hint=0xbfe32378, marshal_data=0xa9c908)
at gtkmarshalers.c:163
#24 0x007360dd in g_type_class_meta_marshal (closure=0x8f7fe68,
return_value=0x0, n_param_values=0,
---Type <return> to continue, or q <return> to quit---
    param_values=0xbfe324b0, invocation_hint=0x0, marshal_data=0x0) at
gclosure.c:514
#25 0x00735e48 in IA__g_closure_invoke (closure=0x8f7fe68, return_value=0x0,
n_param_values=0, param_values=0x0,
    invocation_hint=0x0) at gclosure.c:437
#26 0x00749773 in signal_emit_unlocked_R (node=0x8f7fec0, detail=0,
instance=0x925f2a0, emission_return=0xbfe32440,
    instance_and_params=0xbfe324b0) at gsignal.c:2523
#27 0x0074a9af in IA__g_signal_emit_valist (instance=0x925f2a0, signal_id=0,
detail=0,
    var_args=0xbfe32640
"L&\uffff\uffff@)\uffff\uffffx&\uffff\uffff&\uffff\uffff") at gsignal.c:2254
#28 0x0074af24 in IA__g_signal_emit (instance=0x0, signal_id=0, detail=0) at
gsignal.c:2288
#29 0x00a8faca in IA__gtk_widget_child_focus (widget=0x925f2a0,
direction=GTK_DIR_TAB_FORWARD) at gtkwidget.c:5456
#30 0x00a9c729 in gtk_window_move_focus (window=0x925f2a0,
dir=GTK_DIR_TAB_FORWARD) at gtkwindow.c:4497
#31 0x0074b796 in IA__g_cclosure_marshal_VOID__ENUM (closure=0x8ff92f0,
return_value=0x0, n_param_values=2,
    param_values=0xbfe32940, invocation_hint=0xbfe32808, marshal_data=0xa9c710)
at gmarshal.c:356
#32 0x007360dd in g_type_class_meta_marshal (closure=0x8ff92f0,
return_value=0x0, n_param_values=0,
    param_values=0xbfe32940, invocation_hint=0x0, marshal_data=0x0) at
gclosure.c:514
#33 0x00735e48 in IA__g_closure_invoke (closure=0x8ff92f0, return_value=0x0,
n_param_values=0, param_values=0x0,
    invocation_hint=0x0) at gclosure.c:437
#34 0x00749773 in signal_emit_unlocked_R (node=0x8ffa580, detail=0,
instance=0x925f2a0, emission_return=0x0,
    instance_and_params=0xbfe32940) at gsignal.c:2523
#35 0x0074ac6e in IA__g_signal_emit_valist (instance=0x925f2a0, signal_id=1,
detail=0, var_args=0xbfe32adc "@6v")
    at gsignal.c:2244
#36 0x0074ae2c in IA__g_signal_emit_by_name (instance=0x925f2a0,
detailed_signal=0xab736a "move_focus") at gsignal.c:2312
#37 0x00935e33 in gtk_dialog_map (widget=0x925f2a0) at gtkdialog.c:351
#38 0x0074b2ed in IA__g_cclosure_marshal_VOID__VOID (closure=0x8f2e228,
return_value=0x0, n_param_values=1,
    param_values=0x0, invocation_hint=0xbfe32c78, marshal_data=0x935de5) at
gmarshal.c:77
#39 0x007360dd in g_type_class_meta_marshal (closure=0x8f2e228,
return_value=0x0, n_param_values=0,
    param_values=0xbfe32db0, invocation_hint=0x0, marshal_data=0x0) at
gclosure.c:514
#40 0x00735e48 in IA__g_closure_invoke (closure=0x8f2e228, return_value=0x0,
n_param_values=0, param_values=0x0,
    invocation_hint=0x0) at gclosure.c:437
#41 0x0074955d in signal_emit_unlocked_R (node=0x8f7ec10, detail=0,
instance=0x925f2a0, emission_return=0x0,
    instance_and_params=0xbfe32db0) at gsignal.c:2415
#42 0x0074ac6e in IA__g_signal_emit_valist (instance=0x925f2a0, signal_id=1,
detail=0, var_args=0xbfe32f3c "\uffff)\uffff")
    at gsignal.c:2244
#43 0x0074af24 in IA__g_signal_emit (instance=0x0, signal_id=0, detail=0) at
gsignal.c:2288
#44 0x00a92a18 in IA__gtk_widget_map (widget=0x925f2a0) at gtkwidget.c:2190
#45 0x00a9e318 in gtk_window_show (widget=0x925f2a0) at gtkwindow.c:3857
#46 0x0074b2ed in IA__g_cclosure_marshal_VOID__VOID (closure=0x8f7ea38,
return_value=0x0, n_param_values=1,
    param_values=0x0, invocation_hint=0xbfe33178, marshal_data=0xa9e2cc) at
gmarshal.c:77
---Type <return> to continue, or q <return> to quit---
#47 0x007360dd in g_type_class_meta_marshal (closure=0x8f7ea38,
return_value=0x0, n_param_values=0,
    param_values=0xbfe332b0, invocation_hint=0x0, marshal_data=0x0) at
gclosure.c:514
#48 0x00735e48 in IA__g_closure_invoke (closure=0x8f7ea38, return_value=0x0,
n_param_values=0, param_values=0x0,
    invocation_hint=0x0) at gclosure.c:437
#49 0x0074955d in signal_emit_unlocked_R (node=0x8f7eae0, detail=0,
instance=0x925f2a0, emission_return=0x0,
    instance_and_params=0xbfe332b0) at gsignal.c:2415
#50 0x0074ac6e in IA__g_signal_emit_valist (instance=0x925f2a0, signal_id=1,
detail=0, var_args=0xbfe3343c "_\u0128")
    at gsignal.c:2244
#51 0x0074af24 in IA__g_signal_emit (instance=0x0, signal_id=0, detail=0) at
gsignal.c:2288
#52 0x00a8c4a0 in IA__gtk_widget_show (widget=0x925f2a0) at gtkwidget.c:1997
#53 0x0092731e in gtk_container_show_all (widget=0x925f2a0) at gtkcontainer.c:2325
#54 0x00a8b7d7 in IA__gtk_widget_show_all (widget=0x925f2a0) at gtkwidget.c:2145
#55 0x0805b429 in prepare_importer_page (page=0x900b4d0, druid=0x8fffda0,
data=0x8fb7a90) at e-shell-startup-wizard.c:578
#56 0x0074bc3e in IA__g_cclosure_marshal_VOID__OBJECT (closure=0x91a7408,
return_value=0x0, n_param_values=2,
    param_values=0xbfe337e0, invocation_hint=0xbfe336a8, marshal_data=0x0) at
gmarshal.c:636
#57 0x00735e48 in IA__g_closure_invoke (closure=0x91a7408, return_value=0x0,
n_param_values=0, param_values=0x0,
    invocation_hint=0x0) at gclosure.c:437
#58 0x0074a122 in signal_emit_unlocked_R (node=0x9002bc8, detail=0,
instance=0x900b4d0, emission_return=0x0,
    instance_and_params=0xbfe337e0) at gsignal.c:2555
#59 0x0074ac6e in IA__g_signal_emit_valist (instance=0x900b4d0, signal_id=1,
detail=0, var_args=0xbfe33970 "\005")
    at gsignal.c:2244
#60 0x0074af24 in IA__g_signal_emit (instance=0x0, signal_id=0, detail=0) at
gsignal.c:2288
#61 0x07386a8b in gnome_druid_page_prepare (druid_page=0x900b4d0) at
gnome-druid-page.c:304
#62 0x073850ca in gnome_druid_set_page (druid=0x8fffda0, page=0x8fffd88) at
gnome-druid.c:1058
#63 0x07385abf in gnome_druid_next_callback (button=0x90014a0, druid=0x8fffda0)
at gnome-druid.c:698
#64 0x0074b2ed in IA__g_cclosure_marshal_VOID__VOID (closure=0x9008448,
return_value=0x0, n_param_values=1,
    param_values=0x0, invocation_hint=0xbfe33b48, marshal_data=0x0) at gmarshal.c:77
#65 0x00735e48 in IA__g_closure_invoke (closure=0x9008448, return_value=0x0,
n_param_values=0, param_values=0x0,
    invocation_hint=0x0) at gclosure.c:437
#66 0x00749bde in signal_emit_unlocked_R (node=0x8fff788, detail=0,
instance=0x90014a0, emission_return=0x0,
    instance_and_params=0xbfe33c80) at gsignal.c:2485
#67 0x0074ac6e in IA__g_signal_emit_valist (instance=0x90014a0, signal_id=1,
detail=0, var_args=0xbfe33e0c "\uffff\uffff\216")
    at gsignal.c:2244
#68 0x0074af24 in IA__g_signal_emit (instance=0x0, signal_id=0, detail=0) at
gsignal.c:2288
#69 0x008ec1ea in IA__gtk_button_clicked (button=0x90014a0) at gtkbutton.c:782
#70 0x008eda0d in gtk_real_button_released (button=0x90014a0) at gtkbutton.c:1294
#71 0x0074b2ed in IA__g_cclosure_marshal_VOID__VOID (closure=0x9000ae8,
return_value=0x0, n_param_values=1,
---Type <return> to continue, or q <return> to quit---
    param_values=0x0, invocation_hint=0xbfe33fa8, marshal_data=0x8ed9d0) at
gmarshal.c:77
#72 0x007360dd in g_type_class_meta_marshal (closure=0x9000ae8,
return_value=0x0, n_param_values=0,
    param_values=0xbfe340e0, invocation_hint=0x0, marshal_data=0x0) at
gclosure.c:514
#73 0x00735e48 in IA__g_closure_invoke (closure=0x9000ae8, return_value=0x0,
n_param_values=0, param_values=0x0,
    invocation_hint=0x0) at gclosure.c:437
#74 0x0074955d in signal_emit_unlocked_R (node=0x9000b30, detail=0,
instance=0x90014a0, emission_return=0x0,
    instance_and_params=0xbfe340e0) at gsignal.c:2415
#75 0x0074ac6e in IA__g_signal_emit_valist (instance=0x90014a0, signal_id=1,
detail=0, var_args=0xbfe3426c "\021\uffff\216")
    at gsignal.c:2244
#76 0x0074af24 in IA__g_signal_emit (instance=0x0, signal_id=0, detail=0) at
gsignal.c:2288
#77 0x008ec156 in IA__gtk_button_released (button=0x90014a0) at gtkbutton.c:774
#78 0x008ed097 in gtk_button_button_release (widget=0x0, event=0x0) at
gtkbutton.c:1210
#79 0x009aae9b in _gtk_marshal_BOOLEAN__BOXED (closure=0x8f801d8,
return_value=0xbfe343f0, n_param_values=2,
    param_values=0xbfe34550, invocation_hint=0xbfe34418, marshal_data=0x8ed076)
at gtkmarshalers.c:83
#80 0x007360dd in g_type_class_meta_marshal (closure=0x8f801d8,
return_value=0x0, n_param_values=0,
    param_values=0xbfe34550, invocation_hint=0x0, marshal_data=0x0) at
gclosure.c:514
#81 0x00735e48 in IA__g_closure_invoke (closure=0x8f801d8, return_value=0x0,
n_param_values=0, param_values=0x0,
    invocation_hint=0x0) at gclosure.c:437
#82 0x00749773 in signal_emit_unlocked_R (node=0x8f80210, detail=0,
instance=0x90014a0, emission_return=0xbfe344e0,
    instance_and_params=0xbfe34550) at gsignal.c:2523
#83 0x0074a9af in IA__g_signal_emit_valist (instance=0x90014a0, signal_id=0,
detail=0, var_args=0xbfe346e0 "\uffffF\u3fe0\024")
    at gsignal.c:2254
#84 0x0074af24 in IA__g_signal_emit (instance=0x0, signal_id=0, detail=0) at
gsignal.c:2288
#85 0x00a8d5e8 in gtk_widget_event_internal (widget=0x90014a0, event=0x8f46cd8)
at gtkwidget.c:3616
#86 0x009a9637 in IA__gtk_propagate_event (widget=0x90014a0, event=0x8f46cd8) at
gtkmain.c:2145
#87 0x009a9908 in IA__gtk_main_do_event (event=0x8f46cd8) at gtkmain.c:1383
#88 0x00bbc192 in gdk_event_dispatch (source=0x0, callback=0, user_data=0x0) at
gdkevents-x11.c:2220
#89 0x006c2178 in IA__g_main_context_dispatch (context=0x8f155f0) at gmain.c:1947
#90 0x006c3998 in g_main_context_iterate (context=0x8f155f0, block=1,
dispatch=1, self=0x8ef5308) at gmain.c:2578
#91 0x006c3cbf in IA__g_main_loop_run (loop=0x918b790) at gmain.c:2782
#92 0x009a8cf6 in IA__gtk_main () at gtkmain.c:963
#93 0x0805c62a in e_shell_startup_wizard_create () at e-shell-startup-wizard.c:890
#94 0x080622ff in e_shell_construct (shell=0x8fb4fa8, iid=0x8069248
"OAFIID:GNOME_Evolution_Shell:2.0",
    startup_line_mode=E_SHELL_STARTUP_LINE_MODE_CONFIG) at e-shell.c:646
#95 0x08062430 in e_shell_new
(startup_line_mode=E_SHELL_STARTUP_LINE_MODE_CONFIG,
construct_result_return=0xbfe34a3c)
    at e-shell.c:696
#96 0x08063502 in idle_cb (data=0x0) at main.c:344
---Type <return> to continue, or q <return> to quit---
#97 0x006c5030 in g_idle_dispatch (source=0x8f80c58, callback=0, user_data=0x0)
at gmain.c:3821
#98 0x006c2178 in IA__g_main_context_dispatch (context=0x8f155f0) at gmain.c:1947
#99 0x006c3998 in g_main_context_iterate (context=0x8f155f0, block=1,
dispatch=1, self=0x8ef5308) at gmain.c:2578
#100 0x006c3cbf in IA__g_main_loop_run (loop=0x8f80cd8) at gmain.c:2782
#101 0x003f0dd5 in bonobo_main () at bonobo-main.c:297
#102 0x08063b79 in main (argc=0, argv=0xbfe34f04) at main.c:585
(gdb)
Comment 1 Dave Malcolm 2005-01-21 16:51:04 EST
Looks like this:
http://bugzilla.ximian.com/show_bug.cgi?id=70692

It's a bug in gtk2, mclasen has fixed it in CVS, and hopefully he'll
roll out new packages soon.

What version of gtk2 do you have?
Comment 2 Matthias Clasen 2005-01-21 16:53:58 EST
gtk 2.6.2 is planned for the first week of February
Comment 3 James Laska 2005-01-24 08:45:46 EST
Was using gtk2-2.6.1-1.i386 that currently is in rawhide.
Comment 4 Dave Malcolm 2005-08-18 00:32:14 EDT
Looks like this one was fixed back in February as per comment #2.

Resolving as fixed.

Note You need to log in before you can comment on or make changes to this bug.