Bug 145782 - Network test fails when running through ispec and manually
Network test fails when running through ispec and manually
Status: CLOSED ERRATA
Product: Red Hat Ready Certification Tests
Classification: Retired
Component: ispec (Show other bugs)
2
All Linux
medium Severity medium
: ---
: ---
Assigned To: Will Woods
Richard Li
:
Depends On:
Blocks: 143442
  Show dependency treegraph
 
Reported: 2005-01-21 11:08 EST by Gregg Shick
Modified: 2007-04-18 13:18 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-05-11 12:39:33 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
ispec launched network output.log (5.65 KB, text/plain)
2005-01-21 11:09 EST, Gregg Shick
no flags Details
network test run manually through rhr2 (44.61 KB, text/plain)
2005-01-21 11:11 EST, Gregg Shick
no flags Details

  None (edit)
Description Gregg Shick 2005-01-21 11:08:44 EST
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1; .NET 
CLR 1.0.3705; .NET CLR 1.1.4322)

Description of problem:
I cannot get the network test to pass when running through ispec or 
manually.  

After kicking off the ispec install, I checked 
the /etc/sysconfig/networking/devices || profiles directories, they 
are both empty (on other machines there were configuration files that 
detailed the network setup).  Tried changing TCP settings to "ab -c 
30 -k -n 2000 $ipaddr/httptest.file", still fails. 

On the manual test run, I tried changing the TCP settings to "ab -c 
30 -k -n 2000 $ipaddr/httptest.file", but the test still failed after 
running for a while. I looked at the log file, cannot see any obvious 
error. 

Network test was passing with last release of rhr2 and ispec.  I am 
attaching logs for both network tests. 

Version-Release number of selected component (if applicable):
ispec-1.0-2.noarch.rpm / rhr2-rhel4-1.0-10.noarch.rpm

How reproducible:
Always

Steps to Reproduce:
1. Created ispec server with latest deliverables and latest RC 
release of RHEL4.
2. Launched the test using kickstart file created by ispec. 
3. 
    

Additional info:
Comment 1 Gregg Shick 2005-01-21 11:09:49 EST
Created attachment 110056 [details]
ispec launched network output.log
Comment 2 Gregg Shick 2005-01-21 11:11:26 EST
Created attachment 110058 [details]
network test run manually through rhr2
Comment 3 Richard Li 2005-01-21 11:34:01 EST
The NETWORK test relies on a server in both cases (test machine connects to the
server and performs operations). In both test cases, it appears that the server
might be having issues. In the first, the mount fails, and in the second, the ab
fails while testing eth0 after successfully testing eth1.

I would see about rebooting the iSpec server to see if that frees up any
problems (what version of RHEL is on the iSpec server?).
Comment 4 Gregg Shick 2005-01-21 11:57:01 EST
I will try the reboot.  The ispec server was created with the latest release 
candidate of RHEL4 RHEL4-i386-AS-disc1.iso(2.6.9-5.ELsmp).  I also have a 
couple of ?'s.  

On the ispec run, I noticed on the mount command, it did not list any ip to 
mount, this was not the case on the manual run. 

+ ssh -l root -x 10.0.0.63 'mkdir ~/mnt; mount :/tmp/rhr/NETWORK/export ~/mnt; 
cp ~/mnt/httptest.file ~/httptest.file; 

Here is the line when I run manually:

+ ssh -l root -x 10.0.0.63 'mkdir ~/mnt; mount 
10.0.0.83:/tmp/rhr/NETWORK/export ~/mnt; cp ~/mnt/httptest.file 
~/httptest.file; 

2. Do I need to make sure any services are running on the ispec server for the 
test to work correctly?

3. When I install the OS via ispec, shouldn't my /etc/sysconfig/networking 
directory have eth information?

4.  I noticed on the ispec installed machine, my eth1 refuses to activate 
until I boot into the gui, run the network config tool and save the 
configuration.  Once I save, I can then activate the nic.  
Comment 5 Richard Li 2005-01-21 12:13:28 EST
Do you have DHCP running on your network? If not, did you follow the
instructions for configuring a non-DHCP system in the documentation?
Comment 6 Gregg Shick 2005-01-21 12:21:13 EST
DHCP is running. 
Comment 7 Rob Landry 2005-01-26 11:50:07 EST
After manually configuring the secord port; does the network test
appear  to run correctly?
Comment 8 Richard Li 2005-05-11 12:39:33 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2005-419.html

Note You need to log in before you can comment on or make changes to this bug.