Bug 145803 - kernel 2.6.10-1.737 and 741 broke sound and Cisco VPN client
Summary: kernel 2.6.10-1.737 and 741 broke sound and Cisco VPN client
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel   
(Show other bugs)
Version: 3
Hardware: i686
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Dave Jones
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-01-21 19:35 UTC by Otto
Modified: 2015-01-04 22:16 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-01-21 19:58:44 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Otto 2005-01-21 19:35:21 UTC
Description of problem:
After upgrade to kernel-2.6.10-1.737_FC3 or kernel-2.6.10-1.741_FC3,
the sound stopped working and the Cisco vpnclient-linux-4.6.00.0045-k9
didn't compile.  Both are working fine with kernel-2.6.9-1.681_FC3.

My hardware is a IBM ThinkPad R51

Comment 1 Dave Jones 2005-01-21 19:58:44 UTC
there are already many reports of the broken sound problem in bugzilla.

The cisco problem is a problem that only cisco can help you with.


Comment 2 Otto 2005-01-22 16:32:54 UTC
Broken sound: the problem was the same as the one reported at Bug
#144742: mutting headphone jack sense and line jack sense, the sound
works.

Cisco VPN client: the solution is at
http://www.ces.clemson.edu/linux/vpnclient.shtml

I posted this in order to help someone who could search for this
issues here (like me).

Thanks

Comment 3 Chris 2005-02-21 00:10:22 UTC
Otto!  Thanks for posting your solution link.  

I was having this problem as well @ McMaster University.  
After using the interceptor.c file from your link above with both
patches applied everything appears to be working just fine.

[root@heidrun Profiles]# vpnclient -v
Cisco Systems VPN Client Version 4.6.00 (0045)
Copyright (C) 1998-2004 Cisco Systems, Inc. All Rights Reserved.
Client Type(s): Linux
Running on: Linux 2.6.10-1.766_FC3 #1 Wed Feb 9 23:06:42 EST 2005 i686

Chris

Comment 4 Otto 2005-04-13 00:41:44 UTC
There's a new version of VPN Client at Cisco site that solves the problem with
interceptor.c.
vpnclient-linux-4.6.02.0030-k9.tar.gz.
:-)


Note You need to log in before you can comment on or make changes to this bug.