Bug 145808 - speedtouch shared internet connection intermittent
speedtouch shared internet connection intermittent
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: iptables (Show other bugs)
3
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Thomas Woerner
Ben Levenson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-01-21 15:12 EST by steve martins
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-01-26 12:18:57 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description steve martins 2005-01-21 15:12:22 EST
Description of problem:
Speedtouch Modem configured and installed as described at
http://www.linux-usb.org/SpeedTouch/ - works perfectly on local
machine. Routing configured by guidedog, and also tried by the command:
iptables -t nat -A POSTROUTING -o ppp0 -j MASQUERADE

other computer on network can see the following internet pages on the
internet:
www.yahoo.com, www.google.com, www.aria.com

but other sites fail to load:
www.clearscene.net
www.allposters.com

also email servers can be contacted, but mail doesn't download, and
remote pop box becomes locked on subsequent attempts. result -
unuseable internet connection. All hardware has been running with
peanut linux, 2.4.20, iptables same modem and routing rules without
problem. problem also duplicated on two different machines, with clean
installations

Version-Release number of selected component (if applicable):


How reproducible:
tried on both an intel coppermine processor, and AMD athlon XP 1000
with a Silver speedtouch modem (rev 4), and a btbroadband internet
connection (1Mb ADSL).
speedtouch modem firmware created and installed as described in
website http://www.linux-usb.org/SpeedTouch/ section for Fedora Core 3
port forwarding rules installed by guidedog

Steps to Reproduce:
1.clean install of Fedora Core 3 from CD iso's
2.download and install guidedog
3.place firmware for modem in /lib/firmware
4.add line:
"username@btbroadband.com" "*" "" "*"
to both pap-secrets and chap-secrets
5.create ifcgf-ppp0 file as stated on website, changing VCI and VPN as
appropriate (0, 38 for BT), and add username.
6.configure eth1 as 192.168.0.1, 255.255.255.0
7.set gateway to 192.168.0.1 on a second computer, and connect
8.compare access to sites mentioned above between FC3 machine and
other machine.
  
Actual results:
ping www.yahoo.com : response as expected
ping www.clearscene.net : network unreachable
ping www.allposters.com : network unreachable
ping www.google.com : repsonse as expected

Expected results:
all should return ping

Additional info:
other sites that failed: www.audioguru.biz, www.unionimage.com,
www.salsaestrellas.com - all multihosted at same server.
Comment 1 Thomas Woerner 2005-01-26 12:18:57 EST
There is no name or content filtering in iptables. You have to check your local
configuration or your internet provider.

Closing as not a bug.
Comment 2 steve martins 2005-01-26 13:00:24 EST
This is exactly why I am confused as to why I am getting these results. As far
as my understanding of routing goes, it should not be possible to get the
results I am getting. The ISP and hardware have been ruled out by using an
alternate linux installation, and an XP installation as both routers and
internet browsers without problem. As far as I'm aware, there is nothing in the
configuration that could effect packet filtering, so I suspect it's something
low down, in the way the packets are handled, or NAT error of some description.
I am happy to spend time resolving this issue, but I have exhausted my knowledge
on the subject (note: MEng engineer 6yrs exp. 2yrs with linux - but not
programmer). Any pointers as to what could cause this issue would be greatly
appreciated. 

Note You need to log in before you can comment on or make changes to this bug.