Bug 14585 - anacdump.txt from beta 4 upgrade
anacdump.txt from beta 4 upgrade
Status: CLOSED RAWHIDE
Product: Red Hat Raw Hide
Classification: Retired
Component: anaconda (Show other bugs)
1.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Erik Troan
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-07-24 22:54 EDT by Christopher S. Surridge
Modified: 2008-05-01 11:37 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-07-25 10:03:16 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Christopher S. Surridge 2000-07-24 22:54:31 EDT
I tried the upgrade (as opposed to fresh install) of RedHat 7 beta 4 and
got the following dump, plus an error message saying that the RPM database
could not be built, possibly because I did not have enough disk space. From
a quick df, it looks like I should have more than enough.

Traceback (innermost last):
  File "/usr/bin/anaconda", line 423, in ?
    intf.run(todo, test = test)
  File "/var/tmp/anaconda-7.0//usr/lib/anaconda/gui.py", line 332, in run
    self.icw.run ()
  File "/var/tmp/anaconda-7.0//usr/lib/anaconda/gui.py", line 674, in run
    mainloop ()
  File "/var/tmp/gnome-python-root/usr/lib/python1.5/site-packages/gtk.py",
line 2554, in mainloop
    _gtk.gtk_main()
  File "/var/tmp/gnome-python-root/usr/lib/python1.5/site-packages/gtk.py",
line 125, in __call__
    ret = apply(self.func, a)
  File "/var/tmp/anaconda-7.0//usr/lib/anaconda/gui.py", line 408, in
nextClicked
    next = self.currentScreen.getNext ()
  File "/var/tmp/anaconda-7.0//usr/lib/anaconda/iw/examine_gui.py", line
21, in getNext
    self.todo.upgradeFindPackages (self.root)
  File "/var/tmp/anaconda-7.0//usr/lib/anaconda/todo.py", line 900, in
upgradeFindPackages
    raise RuntimeError, "Rebuild of RPM database failed."
RuntimeError: Rebuild of RPM database failed.

Local variables in innermost frame:
rc: 1
mdList: []
root: hda6
self: <todo.ToDo instance at 828fd10>
win: <gui.WaitWindow instance at 85087e8>

ToDo object:
(itodo
ToDo
p1
(dp2
S'method'
p3
(iimage
CdromInstallMethod
p4
(dp5
S'progressWindow'
p6

output from df:

Filesystem           1k-blocks      Used Available Use% Mounted on
/dev/hda6             19647252   4139260  14509956  22% /
/dev/hda1                15522      6295      8426  43% /boot
/dev/hdb1              6403962   1772697   4299525  29% /scratch
/dev/fd0                  1423        10      1413   1% /mnt/floppy
Comment 1 Erik Troan 2000-07-25 10:03:14 EDT
Already fixed internally :-)

Note You need to log in before you can comment on or make changes to this bug.