Bug 145859 - smartd startup fails (don't add libata disks as they are not supported)
smartd startup fails (don't add libata disks as they are not supported)
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: smartmontools (Show other bugs)
rawhide
athlon Linux
medium Severity medium
: ---
: ---
Assigned To: Tomas Mraz
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-01-22 13:40 EST by Jon Roland
Modified: 2007-11-30 17:10 EST (History)
2 users (show)

See Also:
Fixed In Version: smartmontools-5.33-3
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-11-25 10:20:02 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jon Roland 2005-01-22 13:40:16 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.5)
Gecko/20050104 Fedora/1.7.5-2.1.2.kde

Description of problem:
This appears to be duplicate of bug with same name reported for FC2,
#110747, but bugzilla won't let me post to that bug with a change to
FC3, so entering a new bug. Excerpt from /var/log/messages: 

smartd[4257]: smartd version 5.33 [i386-redhat-linux-gnu] Copyright
(C) 2002-4 Bruce Allen 
kernel: ACPI: PCI Interrupt Link [LFIR] (IRQs 3 4 5 6 7 10 11 12 14
15) *0, disabled.
smartd[4257]: Home page is http://smartmontools.sourceforge.net/  
kernel: ACPI: PCI Interrupt Link [L3CM] (IRQs 3 4 5 6 7 10 11 12 14
15) *0, disabled.
smartd[4257]: Opened configuration file /etc/smartd.conf 
kernel: ACPI: PCI Interrupt Link [LIDE] (IRQs 3 4 5 6 7 10 11 12 14
15) *0, disabled.
smartd[4257]: Configuration file /etc/smartd.conf parsed. 
kernel: ACPI: PCI Interrupt Link [LSID] (IRQs 3 4 5 6 7 *10 11 12 14 15)
smartd[4257]: Device: /dev/sda, opened 
kernel: ACPI: PCI Interrupt Link [LFID] (IRQs 3 4 5 6 7 10 *11 12 14 15)
smartd[4257]: Device /dev/sda, SATA disks accessed via libata are not
currently supported by smartmontools. When libata is given an ATA
pass-thru ioctl() then an additional '-d libata' device type will be
added to smartmontools. 
kernel: ACPI: PCI Interrupt Link [APC1] (IRQs *16), disabled.
smartd[4257]: Unable to register SCSI device /dev/sda at line 1 of
file /etc/smartd.conf 
kernel: ACPI: PCI Interrupt Link [APC2] (IRQs *17), disabled.
smartd[4257]: Unable to register device /dev/sda (no Directive -d
removable). Exiting. 
kernel: ACPI: PCI Interrupt Link [APC3] (IRQs *18), disabled.
smartd: smartd startup failed



Version-Release number of selected component (if applicable):
kernel-2.6.10-1.741_FC3

How reproducible:
Always

Steps to Reproduce:
1. Boot system
2.
3.
    

Additional info:
Comment 1 Jon Roland 2005-01-23 17:48:41 EST
I should add information about my hardware:

Motherboard: DFI nF3 250Gb
Processor: Athlon 64 3400
RAM: 3 GB
HD: Maxtor SATA Ultra 16 300 GB DiamondMax Plus
CD: Toshiba DVD+-R/RW Double Layer
Graphics: ATI All-in-Wonder 9800 Pro
OS: Linux Fedora Core 3 2.6.10-1.741_FC3
Comment 2 Jon Roland 2005-01-23 21:08:05 EST
I was able to find more on the topic, that SATA drives are not yet
suported, and commented out the line in /etc/smartd.conf to disable
smartd.

However, if support for SATA drives is added, I might not get notified
of that so I can uncomment the line in /etc/smartd.conf. If anyone
remembers this when it happens, I would appreciate a notice of that. I
don't want to have to subscribe to yet another list for just that. Thanks.
Comment 3 Eric Wood 2005-09-07 09:26:05 EDT
The /usr/sbin/smartd-conf.py generates the hard drive list (smard.conf) for
smartd to monitor. smartd will also fail to load if there is a mixed environment
of IDE and SCSI.  kudzu.BUS_SCSI should be removed and it will work:

Edit this line in /usr/sbin/smartd-conf.py:
# drives=kudzu.probe(kudzu.CLASS_HD,kudzu.BUS_IDE|kudzu.BUS_SCSI,kudzu.PROBE_ALL)
drives=kudzu.probe(kudzu.CLASS_HD,kudzu.BUS_IDE,kudzu.PROBE_ALL)

In like manor, tt looks like this python script could be modified to detect SATA
drives and skip them.  If /etc/smartd.conf contain no valid lines, the python
script should remove the file and smartd will not complained about a FAILED start.

Note You need to log in before you can comment on or make changes to this bug.