Bug 145884 - Rebuilding Kernel Source RPM gives over 2000 errors.
Rebuilding Kernel Source RPM gives over 2000 errors.
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
3
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Dave Jones
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-01-23 03:00 EST by Brandon Amaro
Modified: 2015-01-04 17:16 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-02-24 02:00:18 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Brandon Amaro 2005-01-23 03:00:13 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.5)
Gecko/20041111 Firefox/1.0

Description of problem:
When I went to go rebuild the kernel source RPM using the command
rpmbuild --rebuild --target='i686' kernel-2.6.10-1.741_FC3.src.rpm, I
got over 2000 errors.

Version-Release number of selected component (if applicable):
kernel-2.6.10-1.741_FC3

How reproducible:
Always

Steps to Reproduce:
1. download the source RPM for kernel-2.6.10-1.741_FC3
2. run this command: rpmbuild --rebuild --target=i686
location_you_saved_the_source_rpm
    

Actual Results:  Failiar to build an RPM.

Expected Results:  A successfull build of the kernel RPM.

Additional info:

This is what appeard before the errors showed up:

+ for i in '*.config'
+ mv kernel-2.6.10-i586-smp.config .config
++ echo kernel-2.6.10-i586-smp.config
++ cut -d- -f3
++ cut -d. -f1
++ sed -e s/i.86/i386/ -e s/s390x/s390/ -e s/ppc64.series/ppc64/
+ make ARCH=i386 nonint_oldconfig

And this is the last few lines of the unseccefull build:

make[5]: *** [nonint_oldconfig] Error 2
make[4]: *** [nonint_oldconfig] Error 2
make[3]: *** [nonint_oldconfig] Error 2
make[2]: *** [nonint_oldconfig] Error 2
make[1]: *** [nonint_oldconfig] Error 2
make: *** [nonint_oldconfig] Error 2
error: Bad exit status from /home/omega13a/rpmbuild/tmp/rpm-tmp.1675
(%prep)


RPM build errors:
    Bad exit status from /home/omega13a/rpmbuild/tmp/rpm-tmp.1675 (%prep)
Comment 1 Dave Jones 2005-01-23 03:30:00 EST
The interesting part is above the bit you snipped.. 
The make[n]: *** are the tail end of whatever happened.

I just did a build locally with exactly the same command line, and it
seems to be working just fine.
Comment 2 Brandon Amaro 2005-01-23 03:56:33 EST
That is odd... I wonder why it worked for you and doesn't work for me...

Anyways here's more of what was happening before the errors:

+ patch -p1 -s
+ cp /home/omega13a/rpmbuild/kernel-2.6.10/COPYING.modules Documentation/
+ mkdir configs
+ cp -fv
/home/omega13a/rpmbuild/kernel-2.6.10/kernel-2.6.10-i586.config
/home/omega13a/rpmbuild/kernel-2.6.10/kernel-2.6.10-i586-smp.config
/home/omega13a/rpmbuild/kernel-2.6.10/kernel-2.6.10-i686.config
/home/omega13a/rpmbuild/kernel-2.6.10/kernel-2.6.10-i686-smp.config .
`/home/omega13a/rpmbuild/kernel-2.6.10/kernel-2.6.10-i586.config' ->
`./kernel-2.6.10-i586.config'
`/home/omega13a/rpmbuild/kernel-2.6.10/kernel-2.6.10-i586-smp.config'
-> `./kernel-2.6.10-i586-smp.config'
`/home/omega13a/rpmbuild/kernel-2.6.10/kernel-2.6.10-i686.config' ->
`./kernel-2.6.10-i686.config'
`/home/omega13a/rpmbuild/kernel-2.6.10/kernel-2.6.10-i686-smp.config'
-> `./kernel-2.6.10-i686-smp.config'
+ for i in '*.config'
+ mv kernel-2.6.10-i586.config .config
++ echo kernel-2.6.10-i586.config
++ cut -d- -f3
++ cut -d. -f1
++ sed -e s/i.86/i386/ -e s/s390x/s390/ -e s/ppc64.series/ppc64/
+ make ARCH=i386 nonint_oldconfig
.config:221: trying to assign nonexistent symbol ACPI_CONTAINER
.config:339: trying to assign nonexistent symbol SCSI_ISCSI_ATTRS
.config:710: trying to assign nonexistent symbol BRIDGE_EBT_ULOG
.config:768: trying to assign nonexistent symbol CLS_U32_MARK
.config:946: trying to assign nonexistent symbol R8169_VLAN
.config:957: trying to assign nonexistent symbol 2BUFF_MODE
.config:1283: trying to assign nonexistent symbol GAMEPORT_CS461x
.config:2550: trying to assign nonexistent symbol CRYPTO_DEV_PADLOCK
.config:2551: trying to assign nonexistent symbol CRYPTO_DEV_PADLOCK_AES
+ cp .config configs/kernel-2.6.10-i586.config
+ for i in '*.config'
+ mv kernel-2.6.10-i586-smp.config .config
++ echo kernel-2.6.10-i586-smp.config
++ cut -d- -f3
++ cut -d. -f1
++ sed -e s/i.86/i386/ -e s/s390x/s390/ -e s/ppc64.series/ppc64/
+ make ARCH=i386 nonint_oldconfig

Before that, it was appling all the patches.

Anyways, could the problem be caused by the fact I'm building the RPM
as the normal user?
Comment 3 Dave Jones 2005-01-23 04:12:55 EST
hmm, still doesn't show any errors.
(The non existant stuff is just a warning, and no big deal)

building as non-root shouldn't make any difference.

Note You need to log in before you can comment on or make changes to this bug.