Bug 145886 - FC3 yum doesn't work with FC2-created repositories
FC3 yum doesn't work with FC2-created repositories
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: yum (Show other bugs)
3
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jeremy Katz
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-01-23 04:25 EST by David Woodhouse
Modified: 2014-01-21 17:51 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-01-23 18:41:26 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description David Woodhouse 2005-01-23 04:25:56 EST
A repository created on a host running FC2 with 'yum-arch' cannot be
used in FC3 by yum; only by up2date. 

This lack of backward compatibility is not normal -- if the metadata
format is to be changed, the old one should continue to be supported
for a reasonable amount of time -- at least one release.
Comment 1 Seth Vidal 2005-01-23 09:48:50 EST
Supporting the old repo format would be an extraordinary pain in the
ass. I don't have the time to put it into and I definitely don't have
the interest.

createrepo runs just fine on fc2, fc1, rhel3 and even rhl9(if you
update libxml2-python to a newer version), there's no reason not to
use it.
Comment 2 David Woodhouse 2005-01-23 18:39:35 EST
It doesn't seem to work on FC2. I tried it and it took 25 minutes to fail:

# yum install createrepo
Gathering header information file(s) from server(s)
Server: Fedora Core 2 - i386 - Base
Server: Fedora Core 2 - i386 - Released Updates
Finding updated packages
Downloading needed headers
gimp-devel-1-2.0.5-0.fc2. 100% |=========================|  22 kB    00:08
xorg-x11-Xvfb-0-6.7.0-11. 100% |=========================|  70 kB    00:19
mozilla-dom-inspector-37- 100% |=========================| 3.8 kB    00:00
kernel-smp-0-2.6.10-1.9_F 100% |=========================| 200 kB    01:04
kdegraphics-devel-7-3.2.2 100% |=========================| 3.9 kB    00:00
perl-Cyrus-0-2.2.10-3.fc2 100% |=========================| 6.7 kB    00:02
mysql-devel-0-3.23.58-9.1 100% |=========================| 7.5 kB    00:03
gstreamer-0-0.8.3-2.i386. 100% |=========================| 6.6 kB    00:01
apr-util-devel-0-0.9.4-14 100% |=========================| 7.8 kB    00:02
glibc-profile-0-2.3.3-27. 100% |=========================|  20 kB    00:03
kdebase-devel-6-3.2.2-8.F 100% |=========================|  16 kB    00:04
postgresql-contrib-0-7.4. 100% |=========================| 8.6 kB    00:03
php-odbc-0-4.3.10-2.4.i38 100% |=========================| 6.2 kB    00:01
xorg-x11-ISO8859-2-75dpi- 100% |=========================|  76 kB    00:28
netatalk-2-1.6.4-2.2.i386 100% |=========================| 9.0 kB    00:02
gnumeric-1-1.2.8-2.i386.h 100% |=========================|  30 kB    00:08
mysql-bench-0-3.23.58-9.1 100% |=========================|  20 kB    00:05
xorg-x11-syriac-fonts-0-6 100% |=========================|  71 kB    00:23
php-mysql-0-4.3.10-2.4.i3 100% |=========================| 6.1 kB    00:01
postgresql-jdbc-0-7.4.6-1 100% |=========================| 3.0 kB    00:00
postgresql-docs-0-7.4.6-1 100% |=========================|  11 kB    00:01
php-devel-0-4.3.10-2.4.i3 100% |=========================|  13 kB    00:06
httpd-devel-0-2.0.51-2.9. 100% |=========================| 8.8 kB    00:04
epiphany-0-1.2.7-0.2.2.i3 100% |=========================| 8.1 kB    00:04
php-domxml-0-4.3.10-2.4.i 100% |=========================| 6.0 kB    00:02
xorg-x11-ISO8859-14-100dp 100% |=========================|  76 kB    00:22
libbonobo-devel-0-2.6.2-1 100% |=========================| 5.0 kB    00:01
cups-devel-1-1.1.20-11.10 100% |=========================| 7.1 kB    00:01
cyrus-imapd-utils-0-2.2.1 100% |=========================| 6.7 kB    00:01
abiword-1-2.0.5-2.i386.hd 100% |=========================|  24 kB    00:07
mysql-server-0-3.23.58-9. 100% |=========================| 7.5 kB    00:02
postgresql-odbc-0-7.3-6.2 100% |=========================| 1.9 kB    00:00
qt-designer-1-3.3.3-0.1.i 100% |=========================|  10 kB    00:03
cyrus-imapd-murder-0-2.2. 100% |=========================| 5.9 kB    00:01
kernel-doc-0-2.6.10-1.9_F 100% |=========================|  35 kB    00:10
subversion-devel-0-1.0.9- 100% |=========================| 5.2 kB    00:00
arpwatch-14-2.1a13-6.FC2. 100% |=========================| 6.2 kB    00:01
xorg-x11-ISO8859-9-75dpi- 100% |=========================|  76 kB    00:29
mysql-0-3.23.58-9.1.i386. 100% |=========================|  12 kB    00:02
freeradius-unixODBC-0-1.0 100% |=========================| 2.9 kB    00:00
qt-PostgreSQL-1-3.3.3-0.1 100% |=========================| 9.2 kB    00:02
gdk-pixbuf-devel-1-0.22.0 100% |=========================| 4.9 kB    00:00
kdegraphics-7-3.2.2-1.1.i 100% |=========================|  31 kB    00:09
k3b-0-0.11.14-0.FC2.2.i38 100% |=========================|  14 kB    00:03
ruby-docs-0-1.8.1-6.FC2.0 100% |=========================|  28 kB    00:09
pcmcia-cs-0-3.2.7-1.8.2.2 100% |=========================| 5.6 kB    00:00
flim-0-1.14.7-0.FC2.noarc 100% |=========================| 4.4 kB    00:00
xorg-x11-ISO8859-15-100dp 100% |=========================|  76 kB    00:24
gimp-1-2.0.5-0.fc2.3.i386 100% |=========================|  44 kB    00:13
libxslt-python-0-1.1.12-2 100% |=========================| 2.7 kB    00:00
xorg-x11-ISO8859-15-75dpi 100% |=========================|  76 kB    00:25
php-snmp-0-4.3.10-2.4.i38 100% |=========================| 6.1 kB    00:02
krb5-workstation-0-1.3.6- 100% |=========================|  12 kB    00:03
postgresql-python-0-7.4.6 100% |=========================| 3.5 kB    00:00
mozilla-devel-37-1.7.3-0. 100% |=========================| 100 kB    00:33
xorg-x11-doc-0-6.7.0-11.i 100% |=========================|  73 kB    00:23
imlib-devel-1-1.9.13-19.i 100% |=========================| 4.1 kB    00:01
neon-devel-0-0.24.7-2.1.i 100% |=========================| 6.6 kB    00:00
kdelibs-6-3.2.2-10.FC2.i3 100% |=========================| 119 kB    00:40
postgresql-test-0-7.4.6-1 100% |=========================|  12 kB    00:03
irb-0-1.8.1-6.FC2.0.i386. 100% |=========================| 6.5 kB    00:01
exim-mon-0-4.43-1.FC2.1.i 100% |=========================| 5.1 kB    00:02
postgresql-tcl-0-7.4.6-1. 100% |=========================| 3.4 kB    00:00
gstreamer-devel-0-0.8.3-2 100% |=========================|  14 kB    00:03
tetex-doc-0-2.0.2-14FC2.2 100% |=========================| 103 kB    00:32
gstreamer-plugins-0-0.8.2 100% |=========================| 9.7 kB    00:02
neon-0-0.24.7-2.1.i386.hd 100% |=========================| 2.6 kB    00:00
devhelp-devel-0-0.9.1-0.2 100% |=========================| 2.3 kB    00:00
mozilla-chat-37-1.7.3-0.2 100% |=========================| 3.3 kB    00:00
mozilla-nspr-devel-37-1.7 100% |=========================| 6.4 kB    00:01
xorg-x11-Xnest-0-6.7.0-11 100% |=========================|  70 kB    00:25
postgresql-server-0-7.4.6 100% |=========================| 7.4 kB    00:02
gnumeric-devel-1-1.2.8-2. 100% |=========================| 3.3 kB    00:01
freeradius-mysql-0-1.0.1- 100% |=========================| 2.9 kB    00:00
ORBit2-devel-0-2.10.0-4.i 100% |=========================| 6.3 kB    00:00
subversion-perl-0-1.0.9-1 100% |=========================| 5.0 kB    00:00
imlib-cfgeditor-1-1.9.13- 100% |=========================| 2.8 kB    00:00
openoffice.org-kde-0-1.1. 100% |=========================| 6.6 kB    00:02
postgresql-pl-0-7.4.6-1.F 100% |=========================| 3.5 kB    00:00
cdda2wav-8-2.01.1-0.FC2.1 100% |=========================| 5.1 kB    00:01
freeradius-0-1.0.1-0.FC2. 100% |=========================|  13 kB    00:01
php-pgsql-0-4.3.10-2.4.i3 100% |=========================| 6.2 kB    00:02
cyrus-imapd-nntp-0-2.2.10 100% |=========================| 5.9 kB    00:00
w3m-img-0-0.5.1-3.1.i386. 100% |=========================| 4.2 kB    00:01
cdrecord-8-2.01.1-0.FC2.1 100% |=========================| 7.1 kB    00:02
ruby-tcltk-0-1.8.1-6.FC2. 100% |=========================|  12 kB    00:03
qt-MySQL-1-3.3.3-0.1.i386 100% |=========================| 9.2 kB    00:03
man-pages-ja-0-20041215-1 100% |=========================|  65 kB    00:21
w3m-0-0.5.1-3.1.i386.hdr  100% |=========================| 6.8 kB    00:01
exim-sa-0-4.43-1.FC2.1.i3 100% |=========================| 5.6 kB    00:01
gnome-applets-1-2.6.2.1-1 100% |=========================|  47 kB    00:14
exim-doc-0-4.43-1.FC2.1.i 100% |=========================|  10 kB    00:01
cyrus-imapd-devel-0-2.2.1 100% |=========================| 6.9 kB    00:02
ruby-libs-0-1.8.1-6.FC2.0 100% |=========================|  24 kB    00:06
qt-ODBC-1-3.3.3-0.1.i386. 100% |=========================| 9.2 kB    00:00
openoffice.org-0-1.1.2-11 100% |=========================|  98 kB    00:35
krb5-server-0-1.3.6-1.i38 100% |=========================|  11 kB    00:03
postgresql-0-7.4.6-1.FC2. 100% |=========================|  28 kB    00:09
vnc-server-0-4.0-5.i386.h 100% |=========================| 4.1 kB    00:00
gpdf-0-2.8.2-2.1.i386.hdr 100% |=========================| 6.7 kB    00:00
xorg-x11-ISO8859-14-75dpi 100% |=========================|  76 kB    00:25
ruby-mode-0-1.8.1-6.FC2.0 100% |=========================| 5.2 kB    00:00
ruby-devel-0-1.8.1-6.FC2. 100% |=========================| 5.6 kB    00:01
libxslt-devel-0-1.1.12-2. 100% |=========================| 3.5 kB    00:00
subversion-0-1.0.9-1.i386 100% |=========================| 9.8 kB    00:02
openmotif21-0-2.1.30-11.F 100% |=========================| 2.9 kB    00:00
php-xmlrpc-0-4.3.10-2.4.i 100% |=========================| 6.0 kB    00:01
gd-progs-0-2.0.21-5.20.1. 100% |=========================| 2.9 kB    00:00
gimp-help-0-2-0.0.3.noarc 100% |=========================|  42 kB    00:14
netatalk-devel-2-1.6.4-2. 100% |=========================| 5.4 kB    00:01
kdelibs-devel-6-3.2.2-10. 100% |=========================| 178 kB    00:59
mozilla-js-debugger-37-1. 100% |=========================| 3.3 kB    00:00
tetex-xdvi-0-2.0.2-14FC2. 100% |=========================|  10 kB    00:01
openoffice.org-libs-0-1.1 100% |=========================|  17 kB    00:04
cdrecord-devel-8-2.01.1-0 100% |=========================| 6.4 kB    00:01
kernel-sourcecode-0-2.6.1 100% |=========================| 501 kB    02:58
glibc-0-2.3.3-27.1.i386.h 100% |=========================|  30 kB    00:10
openoffice.org-i18n-0-1.1 100% |=========================| 138 kB    00:46
sox-devel-0-12.17.4-4.fc2 100% |=========================| 2.5 kB    00:00
MyODBC-0-2.50.39-18.2.i38 100% |=========================| 2.3 kB    00:00
xorg-x11-cyrillic-fonts-0 100% |=========================|  73 kB    00:25
xcdroast-0-0.98a15-6.FC2. 100% |=========================| 6.5 kB    00:01
devhelp-0-0.9.1-0.2.2.i38 100% |=========================| 5.1 kB    00:00
cdrdao-0-1.1.9-4.FC.1.i38 100% |=========================| 3.7 kB    00:01
ruby-0-1.8.1-6.FC2.0.i386 100% |=========================| 9.7 kB    00:04
namazu-cgi-0-2.0.14-0.FC2 100% |=========================| 2.7 kB    00:00
cyrus-sasl-gssapi-0-2.1.1 100% |=========================| 4.6 kB    00:00
namazu-0-2.0.14-0.FC2.0.i 100% |=========================| 7.2 kB    00:02
freeradius-postgresql-0-1 100% |=========================| 2.9 kB    00:00
gstreamer-tools-0-0.8.3-2 100% |=========================| 4.5 kB    00:01
mod_dav_svn-0-1.0.9-1.i38 100% |=========================| 3.4 kB    00:01
mozilla-mail-37-1.7.3-0.2 100% |=========================| 5.6 kB    00:00
mozilla-nss-devel-37-1.7. 100% |=========================| 9.4 kB    00:01
libwnck-devel-0-2.6.0.1-3 100% |=========================| 2.9 kB    00:00
mozilla-37-1.7.3-0.2.0.i3 100% |=========================|  21 kB    00:05
mc-1-4.6.0-17.fc2.i386.hd 100% |=========================|  12 kB    00:04
namazu-devel-0-2.0.14-0.F 100% |=========================| 3.4 kB    00:01
xorg-x11-ISO8859-9-100dpi 100% |=========================|  76 kB    00:25
xorg-x11-sdk-0-6.7.0-11.i 100% |=========================| 104 kB    00:35
dvd+rw-tools-0-5.21.4.10. 100% |=========================| 2.2 kB    00:00
kdebase-6-3.2.2-8.FC2.i38 100% |=========================| 116 kB    00:42
samba-swat-0-3.0.10-1.fc2 100% |=========================|  25 kB    00:08
flim-xemacs-0-1.14.7-0.FC 100% |=========================| 4.5 kB    00:00
kernel-0-2.6.10-1.9_FC2.i 100% |=========================| 200 kB    01:02
gstreamer-plugins-devel-0 100% |=========================| 4.9 kB    00:01
xorg-x11-ISO8859-2-100dpi 100% |=========================|  76 kB    00:28
Cannot find a package matching createrepo
No actions to take
Comment 3 Seth Vidal 2005-01-23 18:41:26 EST
http://linux.duke.edu/projects/metadata/generate//createrepo-0.4.2-1.src.rpm

download that
rebuild it on fc2.

install it.

done.

Note You need to log in before you can comment on or make changes to this bug.