Bug 145890 - PHP does not have tidy support compiled
PHP does not have tidy support compiled
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: php (Show other bugs)
rawhide
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Joe Orton
David Lawrence
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-01-23 05:52 EST by Simon Mundy
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-07-17 13:36:51 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Simon Mundy 2005-01-23 05:52:15 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Macintosh; U; PPC Mac OS X; en) AppleWebKit/125.5.5 (KHTML, like Gecko) Safari/125.12

Description of problem:
PHP does not come compiled with Tidy support built in, and the PECL/PEAR installer installs the incorrect (i.e. non-OO) version of Tidy

Is it possible to add '--with-tidy' to the configure script?

I did notice that Tidy / Libtidy is not in the 'devel' build of FC3 - is this up for review?

Version-Release number of selected component (if applicable):
php-5.0.3-1

How reproducible:
Always

Steps to Reproduce:
1.
2.
3.
    

Additional info:
Comment 1 Joe Orton 2005-01-24 11:46:45 EST
I'm afraid I am going to systematically WONTFIX requests to enable PHP
extensions which rely on third-party packages which are not currently
included in Fedora Core, since there are so many which could be
requested.  I suggest one of:

1) join fedora-devel-list@redhat.com and argue why the particular
library package should be included: is it worth it on its own, or is
it just for PHP?

2) package the extension and the library on which it depends in Fedora
Extras
Comment 2 Simon Mundy 2005-07-17 08:33:06 EDT
Can this re-opened as Tidy is now included in extras?
Comment 3 Joe Orton 2005-07-17 13:36:51 EDT
Packages in Core cannot depend on packages in Extras.  You could make a php-tidy
package in Extras now, though.

Note You need to log in before you can comment on or make changes to this bug.