Bug 145897 - Localized versions of firefox in future releases
Localized versions of firefox in future releases
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: firefox (Show other bugs)
3
All Linux
medium Severity medium
: ---
: ---
Assigned To: Christopher Aillon
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-01-23 08:42 EST by Josep
Modified: 2007-11-30 17:10 EST (History)
4 users (show)

See Also:
Fixed In Version: FC5
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-04-14 06:00:24 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Josep 2005-01-23 08:42:32 EST
Description of problem:
Currently Fedora Core ships with no localized versions of Firefox.

The desktop without a localized web browser is unusable for
non-english speaking users, thus Fedora Core should install localized
versions for each installed language by default.

Version-Release number of selected component (if applicable):

How reproducible:
Always

Steps to Reproduce:
1. install fedora and select a non-english locale
2. enter as a user (selecting a non-english locale)
3. run firefox
    

Actual Results:  Firefox is in English

Expected Results:  Firefox should be localized

Additional info:

There are a couple of bug reports here in bugzilla about this: #139290
and #144251, which are marked as possible duplicates of #137134.

Since #137134 refers only to RHEL (and only to the languages it
supports), and since the previously mentioned bugs refer only to
particular locales (no_NO and pt_BR), I file a new bug aimed to all
languages (feel free to mark it as duplicated, and I apologize for the
extra work this might cause you).

Contrary to what is said in a comment in bug #137134, localized
versions of Firefox seem to be coordinated through the Mozilla
Localization Project (MLP):
http://www.mozilla.org/projects/l10n/mlp.html
(mabye MPL is posterior to that comment)
Comment 1 Remi COLLET 2005-04-02 04:41:59 EST
I'm working on building RPM for my locale (firefox and thunderbird in french).

I think this could be useful for all the fedora users, but the english one :-)

To do this a use '-install-global-extension' but this options requires
- a profile
- X running

So my "working RPM" can't be used during installation process.

There is a patch in CVS call "nox-patch" usefull for this (already include in
some other distro).

The '-uninstall-global-extension' will be very useful too (already in CVS).

The "pref("intl.locale.matchOS", true);" 

More informations in "Moz bug #265859"
(https://bugzilla.mozilla.org/show_bug.cgi?id=265859)
Comment 2 Josep 2006-04-14 06:00:24 EDT
This is solved as for Fedora Core 5 by installing the appropiated language pack.

Note You need to log in before you can comment on or make changes to this bug.