Bug 1459038 - engine-setup installs openvswitch-ovn-host during OVN installation
engine-setup installs openvswitch-ovn-host during OVN installation
Status: CLOSED CURRENTRELEASE
Product: ovirt-engine
Classification: oVirt
Component: BLL.Network (Show other bugs)
4.2.0
Unspecified Unspecified
medium Severity medium (vote)
: ovirt-4.2.0
: ---
Assigned To: Marcin Mirecki
Meni Yakove
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2017-06-06 03:28 EDT by Mor
Modified: 2017-12-20 06:01 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-12-20 06:01:17 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Network
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
rule-engine: ovirt‑4.2+


Attachments (Terms of Use)

  None (edit)
Description Mor 2017-06-06 03:28:24 EDT
Description of problem:
When using engine-setup to install ovirt-provider-ovn it also installs the openvswitch-ovn-host package.

# engine-setup
[ INFO  ] Stage: Initializing
[ INFO  ] Stage: Environment setup
          Configuration files: ['/etc/ovirt-engine-setup.conf.d/10-packaging-jboss.conf', '/etc/ovirt-engine-setup.conf.d/10-packaging.conf', '/etc/ovirt-engine-setup.conf.d/20-setup-ovirt-post.conf']
          Log file: /var/log/ovirt-engine/setup/ovirt-engine-setup-20170604090639-em0f54.log
          Version: otopi-1.7.0_master (otopi-1.7.0-0.0.master.20170504102220.git4fe9afe.el7.centos)
[ INFO  ] Stage: Environment packages setup
[ INFO  ] Stage: Programs detection
[ INFO  ] Stage: Environment setup
[ INFO  ] Stage: Environment customization
        
          --== PRODUCT OPTIONS ==--
        
        
          --== PACKAGES ==--
        
          Install ovirt-provider-ovn(Yes, No) [Yes]?:
[ INFO  ] Checking for product updates...
          Setup has found updates for some packages:
          [install] openvswitch-ovn-host-2.7.0-1.el7.centos.x86_64 will be installed
          do you wish to update them now? (Yes, No) [Yes]: 


Version-Release number of selected component (if applicable):


How reproducible:
100%

Steps to Reproduce:
1. Run engine-setup.
2. Answer 'Yes' to 'Install ovirt-provider-ovn(Yes, No) [Yes]?:'.
3. engine-setup checks for product updates and wants to install 'openvswitch-ovn-host' package.

Actual results:
openvswitch-ovn-host package is installed.

Expected results:
It should not be installed on central server.

Additional info:
Comment 1 Mor 2017-06-06 03:29:53 EDT
oVirt Version:
Version 4.2.0-0.0.master.20170531203202.git1bf6667.el7.centos
Comment 3 Marcin Mirecki 2017-06-09 04:13:58 EDT
Fixed by: https://gerrit.ovirt.org/#/c/77871/
Comment 4 Mor 2017-06-11 02:29:33 EDT
Verified on:
oVirt Version 4.2.0-0.0.master.20170606135217.gita02bf9d.el7.centos
Comment 5 Sandro Bonazzola 2017-12-20 06:01:17 EST
This bugzilla is included in oVirt 4.2.0 release, published on Dec 20th 2017.

Since the problem described in this bug report should be
resolved in oVirt 4.2.0 release, published on Dec 20th 2017, it has been closed with a resolution of CURRENT RELEASE.

If the solution does not work for you, please open a new bug report.

Note You need to log in before you can comment on or make changes to this bug.