Bug 1459063 - Failed dependencies when installing heartbeat on RHEL 6.8
Failed dependencies when installing heartbeat on RHEL 6.8
Status: NEW
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: yum (Show other bugs)
6.8
x86_64 Linux
unspecified Severity urgent
: rc
: ---
Assigned To: Valentina Mukhamedzhanova
BaseOS QE Security Team
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2017-06-06 04:20 EDT by Vishnu G Singhal
Modified: 2017-06-06 04:20 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed:
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Vishnu G Singhal 2017-06-06 04:20:20 EDT
Description of problem:
Failed dependencies when installing heartbeat on RHEL 6

Version-Release number of selected component (if applicable):

Cannot install heartbeat on RHEL 6.
Failed dependencies on libplumbgpl.so.2 and cluster-glue.
I have also tried to install using RHEL SUbscription repo & EPEL repo.

How reproducible:


Steps to Reproduce:
1.mkdir /root/heart/
2.yum --downloadonly install libplumbgpl  --downloaddir=/root/heart/
3.


Actual results:
Loaded plugins: product-id, rhnplugin, search-disabled-repos, security, subscription-manager
This system is receiving updates from RHN Classic or RHN Satellite.
Setting up Install Process
No package libplumbgpl available.
Error: Nothing to do
[root@SI02F700C3-6-23-vgopalsingha heart]# yum --downloadonly install libplumbgpl  --downloaddir=/root/heart/
Loaded plugins: product-id, rhnplugin, search-disabled-repos, security, subscription-manager
This system is receiving updates from RHN Classic or RHN Satellite.
Setting up Install Process
No package libplumbgpl available.
Error: Nothing to do
[root@SI02F700C3-6-23-vgopalsingha heart]# yum --downloadonly install heartbeat  --downloaddir=/root/heart/
Loaded plugins: product-id, rhnplugin, search-disabled-repos, security, subscription-manager
This system is receiving updates from RHN Classic or RHN Satellite.
Setting up Install Process
Resolving Dependencies
--> Running transaction check
---> Package heartbeat.x86_64 0:3.0.4-2.el6 will be installed
--> Processing Dependency: resource-agents for package: heartbeat-3.0.4-2.el6.x86_64
--> Processing Dependency: cluster-glue-libs for package: heartbeat-3.0.4-2.el6.x86_64
--> Processing Dependency: cluster-glue for package: heartbeat-3.0.4-2.el6.x86_64
--> Processing Dependency: libplumb.so.2()(64bit) for package: heartbeat-3.0.4-2.el6.x86_64
--> Processing Dependency: libltdl.so.7()(64bit) for package: heartbeat-3.0.4-2.el6.x86_64
--> Processing Dependency: libhbclient.so.1()(64bit) for package: heartbeat-3.0.4-2.el6.x86_64
--> Processing Dependency: libapphb.so.2()(64bit) for package: heartbeat-3.0.4-2.el6.x86_64
--> Running transaction check
---> Package heartbeat.x86_64 0:3.0.4-2.el6 will be installed
--> Processing Dependency: cluster-glue-libs for package: heartbeat-3.0.4-2.el6.x86_64
--> Processing Dependency: cluster-glue for package: heartbeat-3.0.4-2.el6.x86_64
--> Processing Dependency: libplumb.so.2()(64bit) for package: heartbeat-3.0.4-2.el6.x86_64
---> Package heartbeat-libs.x86_64 0:3.0.4-2.el6 will be installed
--> Processing Dependency: libstonith.so.1()(64bit) for package: heartbeat-libs-3.0.4-2.el6.x86_64
--> Processing Dependency: libplumbgpl.so.2()(64bit) for package: heartbeat-libs-3.0.4-2.el6.x86_64
--> Processing Dependency: libplumb.so.2()(64bit) for package: heartbeat-libs-3.0.4-2.el6.x86_64
--> Processing Dependency: libpils.so.2()(64bit) for package: heartbeat-libs-3.0.4-2.el6.x86_64
---> Package libtool-ltdl.x86_64 0:2.2.6-15.5.el6 will be installed
---> Package resource-agents.x86_64 0:3.9.2-40.el6 will be installed
--> Finished Dependency Resolution
Error: Package: heartbeat-libs-3.0.4-2.el6.x86_64 (epel)
           Requires: libplumbgpl.so.2()(64bit)
Error: Package: heartbeat-libs-3.0.4-2.el6.x86_64 (epel)
           Requires: libpils.so.2()(64bit)
Error: Package: heartbeat-3.0.4-2.el6.x86_64 (epel)
           Requires: libplumb.so.2()(64bit)
Error: Package: heartbeat-libs-3.0.4-2.el6.x86_64 (epel)
           Requires: libplumb.so.2()(64bit)
Error: Package: heartbeat-libs-3.0.4-2.el6.x86_64 (epel)
           Requires: libstonith.so.1()(64bit)
Error: Package: heartbeat-3.0.4-2.el6.x86_64 (epel)
           Requires: cluster-glue
Error: Package: heartbeat-3.0.4-2.el6.x86_64 (epel)
           Requires: cluster-glue-libs
**********************************************************************
yum can be configured to try to resolve such errors by temporarily enabling
disabled repos and searching for missing dependencies.
To enable this functionality please set 'notify_only=0' in /etc/yum/pluginconf.d/search-disabled-repos.conf
**********************************************************************

Error: Package: heartbeat-libs-3.0.4-2.el6.x86_64 (epel)
           Requires: libplumbgpl.so.2()(64bit)
Error: Package: heartbeat-libs-3.0.4-2.el6.x86_64 (epel)
           Requires: libpils.so.2()(64bit)
Error: Package: heartbeat-3.0.4-2.el6.x86_64 (epel)
           Requires: libplumb.so.2()(64bit)
Error: Package: heartbeat-libs-3.0.4-2.el6.x86_64 (epel)
           Requires: libplumb.so.2()(64bit)
Error: Package: heartbeat-libs-3.0.4-2.el6.x86_64 (epel)
           Requires: libstonith.so.1()(64bit)
Error: Package: heartbeat-3.0.4-2.el6.x86_64 (epel)
           Requires: cluster-glue
Error: Package: heartbeat-3.0.4-2.el6.x86_64 (epel)
           Requires: cluster-glue-libs
 You could try using --skip-broken to work around the problem
 You could try running: rpm -Va --nofiles --nodigest


Expected results:
Heartbeat should be installed.

Additional info:
I have epel repo and RHEL subscription repo attached.Also I do have my system registered with RHEL.  System ID registered with RHEL: ID-1041056966

Note You need to log in before you can comment on or make changes to this bug.