Bug 1459232 - Dependency missing when installing katello-agent from Satellite Tools 6.3 repository internal compose
Dependency missing when installing katello-agent from Satellite Tools 6.3 rep...
Status: CLOSED ERRATA
Product: Red Hat Satellite 6
Classification: Red Hat
Component: Packaging (Show other bugs)
6.3.0
x86_64 Linux
unspecified Severity high (vote)
: Beta
: --
Assigned To: satellite6-bugs
Nikhil Kathole
: AutomationBlocker, Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2017-06-06 11:04 EDT by Djebran Lezzoum
Modified: 2018-02-21 12:09 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2018-02-21 12:09:43 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Comment 2 Nikhil Kathole 2017-09-05 02:47:29 EDT
Hi,

While installing katello-agent on content host with satellite 6 tools repo/capsule repo, python2-tracer and python-pulp-agent-lib dependency got resolved but another dependency python-six won't get resolved. So while verifying this bug is that expected to sync satellite 6 repo and rhel base OS repo also?
Comment 3 Nikhil Kathole 2017-09-27 03:17:21 EDT
VERIFIED

Version Tested:
Satellite-6.3 Snap 17

steps:

1. # yum repolist
Loaded plugins: product-id, search-disabled-repos, subscription-manager
repo id                                                           repo name                                                        status
!Default_Organization_Sat6Tools7_sat6tool7                        sat6tool7                                                            62
!rhel-7-server-rpms/7Server/x86_64                                Red Hat Enterprise Linux 7 Server (RPMs)                         17,241
repolist: 17,303


2. # yum -y install katello-agent
Loaded plugins: product-id, search-disabled-repos, subscription-manager
Default_Organization_Sat6Tools7_sat6tool7                                                                         | 2.1 kB  00:00:00
rhel-7-server-rpms                                                                                                | 2.0 kB  00:00:00
Resolving Dependencies
--> Running transaction check
---> Package katello-agent.noarch 0:3.0.2-2.el7sat will be installed
--> Processing Dependency: python-pulp-agent-lib >= 2.6 for package: katello-agent-3.0.2-2.el7sat.noarch
--> Processing Dependency: python-gofer-proton >= 2.5 for package: katello-agent-3.0.2-2.el7sat.noarch
--> Processing Dependency: pulp-rpm-handlers >= 2.6 for package: katello-agent-3.0.2-2.el7sat.noarch
--> Processing Dependency: gofer >= 2.7.6 for package: katello-agent-3.0.2-2.el7sat.noarch
--> Processing Dependency: katello-host-tools for package: katello-agent-3.0.2-2.el7sat.noarch
--> Running transaction check
---> Package gofer.noarch 0:2.7.7-2.el7sat will be installed
--> Processing Dependency: python-gofer = 2.7.7 for package: gofer-2.7.7-2.el7sat.noarch
---> Package katello-host-tools.noarch 0:3.0.2-2.el7sat will be installed
--> Processing Dependency: python2-tracer >= 0.6.12 for package: katello-host-tools-3.0.2-2.el7sat.noarch
--> Processing Dependency: katello-host-tools-fact-plugin for package: katello-host-tools-3.0.2-2.el7sat.noarch
---> Package pulp-rpm-handlers.noarch 0:2.13.3-1.el7sat will be installed
--> Processing Dependency: python-pulp-rpm-common = 2.13.3 for package: pulp-rpm-handlers-2.13.3-1.el7sat.noarch
---> Package python-gofer-proton.noarch 0:2.7.7-2.el7sat will be installed
--> Processing Dependency: python-qpid-proton >= 0.9-5 for package: python-gofer-proton-2.7.7-2.el7sat.noarch
---> Package python-pulp-agent-lib.noarch 0:2.13.3-1.el7sat will be installed
--> Processing Dependency: python-pulp-common = 2.13.3 for package: python-pulp-agent-lib-2.13.3-1.el7sat.noarch
--> Running transaction check
---> Package katello-host-tools-fact-plugin.noarch 0:3.0.2-2.el7sat will be installed
---> Package python-gofer.noarch 0:2.7.7-2.el7sat will be installed
---> Package python-pulp-common.noarch 0:2.13.3-1.el7sat will be installed
--> Processing Dependency: python-isodate >= 0.5.0-1.pulp for package: python-pulp-common-2.13.3-1.el7sat.noarch
---> Package python-pulp-rpm-common.noarch 0:2.13.3-1.el7sat will be installed
---> Package python-qpid-proton.x86_64 0:0.16.0-7.el7 will be installed
--> Processing Dependency: qpid-proton-c(x86-64) = 0.16.0-7.el7 for package: python-qpid-proton-0.16.0-7.el7.x86_64
--> Processing Dependency: libqpid-proton.so.10()(64bit) for package: python-qpid-proton-0.16.0-7.el7.x86_64
---> Package python2-tracer.noarch 0:0.6.13-2.el7sat will be installed
--> Processing Dependency: tracer-common = 0.6.13-2.el7sat for package: python2-tracer-0.6.13-2.el7sat.noarch
--> Processing Dependency: python-psutil for package: python2-tracer-0.6.13-2.el7sat.noarch
--> Processing Dependency: python-beautifulsoup4 for package: python2-tracer-0.6.13-2.el7sat.noarch
--> Processing Dependency: python-argcomplete for package: python2-tracer-0.6.13-2.el7sat.noarch
--> Running transaction check
---> Package python-argcomplete.noarch 0:1.7.0-1.el7sat will be installed
---> Package python-beautifulsoup4.noarch 0:4.3.2-1.el7sat will be installed
--> Processing Dependency: python-html5lib for package: python-beautifulsoup4-4.3.2-1.el7sat.noarch
---> Package python-isodate.noarch 0:0.5.0-5.pulp.el7sat will be installed
---> Package python-psutil.x86_64 0:5.0.1-1.el7sat will be installed
---> Package qpid-proton-c.x86_64 0:0.16.0-7.el7 will be installed
---> Package tracer-common.noarch 0:0.6.13-2.el7sat will be installed
--> Running transaction check
---> Package python-html5lib.noarch 1:0.999-1.el7sat will be installed
--> Processing Dependency: python-six for package: 1:python-html5lib-0.999-1.el7sat.noarch
--> Running transaction check
---> Package python-six.noarch 0:1.9.0-2.el7 will be installed
--> Finished Dependency Resolution

Dependencies Resolved

=========================================================================================================================================
 Package                               Arch          Version                      Repository                                        Size
=========================================================================================================================================
Installing:
 katello-agent                         noarch        3.0.2-2.el7sat               Default_Organization_Sat6Tools7_sat6tool7         25 k
Installing for dependencies:
 gofer                                 noarch        2.7.7-2.el7sat               Default_Organization_Sat6Tools7_sat6tool7         85 k
 katello-host-tools                    noarch        3.0.2-2.el7sat               Default_Organization_Sat6Tools7_sat6tool7         19 k
 katello-host-tools-fact-plugin        noarch        3.0.2-2.el7sat               Default_Organization_Sat6Tools7_sat6tool7         11 k
 pulp-rpm-handlers                     noarch        2.13.3-1.el7sat              Default_Organization_Sat6Tools7_sat6tool7         72 k
 python-argcomplete                    noarch        1.7.0-1.el7sat               Default_Organization_Sat6Tools7_sat6tool7         48 k
 python-beautifulsoup4                 noarch        4.3.2-1.el7sat               Default_Organization_Sat6Tools7_sat6tool7        148 k
 python-gofer                          noarch        2.7.7-2.el7sat               Default_Organization_Sat6Tools7_sat6tool7        133 k
 python-gofer-proton                   noarch        2.7.7-2.el7sat               Default_Organization_Sat6Tools7_sat6tool7         54 k
 python-html5lib                       noarch        1:0.999-1.el7sat             Default_Organization_Sat6Tools7_sat6tool7        205 k
 python-isodate                        noarch        0.5.0-5.pulp.el7sat          Default_Organization_Sat6Tools7_sat6tool7         50 k
 python-psutil                         x86_64        5.0.1-1.el7sat               Default_Organization_Sat6Tools7_sat6tool7        287 k
 python-pulp-agent-lib                 noarch        2.13.3-1.el7sat              Default_Organization_Sat6Tools7_sat6tool7         91 k
 python-pulp-common                    noarch        2.13.3-1.el7sat              Default_Organization_Sat6Tools7_sat6tool7        123 k
 python-pulp-rpm-common                noarch        2.13.3-1.el7sat              Default_Organization_Sat6Tools7_sat6tool7         65 k
 python-qpid-proton                    x86_64        0.16.0-7.el7                 Default_Organization_Sat6Tools7_sat6tool7        216 k
 python-six                            noarch        1.9.0-2.el7                  rhel-7-server-rpms                                29 k
 python2-tracer                        noarch        0.6.13-2.el7sat              Default_Organization_Sat6Tools7_sat6tool7        104 k
 qpid-proton-c                         x86_64        0.16.0-7.el7                 Default_Organization_Sat6Tools7_sat6tool7        131 k
 tracer-common                         noarch        0.6.13-2.el7sat              Default_Organization_Sat6Tools7_sat6tool7         25 k

Transaction Summary
=========================================================================================================================================
Install  1 Package (+19 Dependent packages)

Total download size: 1.9 M
Installed size: 7.2 M
Downloading packages:
(1/20): katello-agent-3.0.2-2.el7sat.noarch.rpm                                                                   |  25 kB  00:00:00
(2/20): gofer-2.7.7-2.el7sat.noarch.rpm                                                                           |  85 kB  00:00:00
(3/20): katello-host-tools-3.0.2-2.el7sat.noarch.rpm                                                              |  19 kB  00:00:00
(4/20): katello-host-tools-fact-plugin-3.0.2-2.el7sat.noarch.rpm                                                  |  11 kB  00:00:00
(5/20): pulp-rpm-handlers-2.13.3-1.el7sat.noarch.rpm                                                              |  72 kB  00:00:00
(6/20): python-argcomplete-1.7.0-1.el7sat.noarch.rpm                                                              |  48 kB  00:00:00
(7/20): python-beautifulsoup4-4.3.2-1.el7sat.noarch.rpm                                                           | 148 kB  00:00:00
(8/20): python-gofer-2.7.7-2.el7sat.noarch.rpm                                                                    | 133 kB  00:00:00
(9/20): python-gofer-proton-2.7.7-2.el7sat.noarch.rpm                                                             |  54 kB  00:00:00
(10/20): python-html5lib-0.999-1.el7sat.noarch.rpm                                                                | 205 kB  00:00:00
(11/20): python-isodate-0.5.0-5.pulp.el7sat.noarch.rpm                                                            |  50 kB  00:00:00
(12/20): python-psutil-5.0.1-1.el7sat.x86_64.rpm                                                                  | 287 kB  00:00:00
(13/20): python-pulp-agent-lib-2.13.3-1.el7sat.noarch.rpm                                                         |  91 kB  00:00:00
(14/20): python-pulp-common-2.13.3-1.el7sat.noarch.rpm                                                            | 123 kB  00:00:00
(15/20): python-pulp-rpm-common-2.13.3-1.el7sat.noarch.rpm                                                        |  65 kB  00:00:00
(16/20): python-qpid-proton-0.16.0-7.el7.x86_64.rpm                                                               | 216 kB  00:00:00
(17/20): python2-tracer-0.6.13-2.el7sat.noarch.rpm                                                                | 104 kB  00:00:00
(18/20): qpid-proton-c-0.16.0-7.el7.x86_64.rpm                                                                    | 131 kB  00:00:00
(19/20): tracer-common-0.6.13-2.el7sat.noarch.rpm                                                                 |  25 kB  00:00:00
warning: /var/cache/yum/x86_64/7Server/rhel-7-server-rpms/packages/python-six-1.9.0-2.el7.noarch.rpm: Header V3 RSA/SHA256 Signature, key
 ID fd431d51: NOKEY
Public key for python-six-1.9.0-2.el7.noarch.rpm is not installed
(20/20): python-six-1.9.0-2.el7.noarch.rpm                                                                        |  29 kB  00:00:00
-----------------------------------------------------------------------------------------------------------------------------------------
Total                                                                                                    2.0 MB/s | 1.9 MB  00:00:00
Retrieving key from file:///etc/pki/rpm-gpg/RPM-GPG-KEY-redhat-release
Importing GPG key 0xFD431D51:
 Userid     : "Red Hat, Inc. (release key 2) <security@redhat.com>"
 Fingerprint: 567e 347a d004 4ade 55ba 8a5f 199e 2f91 fd43 1d51
 Package    : redhat-release-server-7.4-18.el7.x86_64 (@beaker-Server/7.4)
 From       : /etc/pki/rpm-gpg/RPM-GPG-KEY-redhat-release
Importing GPG key 0x2FA658E0:
 Userid     : "Red Hat, Inc. (auxiliary key) <security@redhat.com>"
 Fingerprint: 43a6 e49c 4a38 f4be 9abf 2a53 4568 9c88 2fa6 58e0
 Package    : redhat-release-server-7.4-18.el7.x86_64 (@beaker-Server/7.4)
 From       : /etc/pki/rpm-gpg/RPM-GPG-KEY-redhat-release
Running transaction check
Running transaction test
Transaction test succeeded
Running transaction
Warning: RPMDB altered outside of yum.
  Installing : python-gofer-2.7.7-2.el7sat.noarch                                                                                   1/20
  Installing : gofer-2.7.7-2.el7sat.noarch                                                                                          2/20
  Installing : tracer-common-0.6.13-2.el7sat.noarch                                                                                 3/20
  Installing : python-isodate-0.5.0-5.pulp.el7sat.noarch                                                                            4/20
  Installing : python-pulp-common-2.13.3-1.el7sat.noarch                                                                            5/20
  Installing : python-pulp-agent-lib-2.13.3-1.el7sat.noarch                                                                         6/20
  Installing : python-pulp-rpm-common-2.13.3-1.el7sat.noarch                                                                        7/20
  Installing : pulp-rpm-handlers-2.13.3-1.el7sat.noarch                                                                             8/20
  Installing : python-six-1.9.0-2.el7.noarch                                                                                        9/20
  Installing : 1:python-html5lib-0.999-1.el7sat.noarch                                                                             10/20
  Installing : python-beautifulsoup4-4.3.2-1.el7sat.noarch                                                                         11/20
  Installing : qpid-proton-c-0.16.0-7.el7.x86_64                                                                                   12/20
  Installing : python-qpid-proton-0.16.0-7.el7.x86_64                                                                              13/20
  Installing : python-gofer-proton-2.7.7-2.el7sat.noarch                                                                           14/20
  Installing : katello-host-tools-fact-plugin-3.0.2-2.el7sat.noarch                                                                15/20
  Installing : python-argcomplete-1.7.0-1.el7sat.noarch                                                                            16/20
  Installing : python-psutil-5.0.1-1.el7sat.x86_64                                                                                 17/20
  Installing : python2-tracer-0.6.13-2.el7sat.noarch                                                                               18/20
  Installing : katello-host-tools-3.0.2-2.el7sat.noarch                                                                            19/20
  Installing : katello-agent-3.0.2-2.el7sat.noarch                                                                                 20/20
Note: Forwarding request to 'systemctl enable goferd.service'.
Created symlink from /etc/systemd/system/multi-user.target.wants/goferd.service to /usr/lib/systemd/system/goferd.service.
Loaded plugins: product-id
rhel-7-server-rpms/7Server/x86_64/productid                                                                       | 2.1 kB  00:00:00
  Verifying  : python-pulp-agent-lib-2.13.3-1.el7sat.noarch                                                                         1/20
  Verifying  : python2-tracer-0.6.13-2.el7sat.noarch                                                                                2/20
  Verifying  : python-psutil-5.0.1-1.el7sat.x86_64                                                                                  3/20
  Verifying  : katello-agent-3.0.2-2.el7sat.noarch                                                                                  4/20
  Verifying  : python-argcomplete-1.7.0-1.el7sat.noarch                                                                             5/20
  Verifying  : katello-host-tools-fact-plugin-3.0.2-2.el7sat.noarch                                                                 6/20
  Verifying  : qpid-proton-c-0.16.0-7.el7.x86_64                                                                                    7/20
  Verifying  : python-gofer-2.7.7-2.el7sat.noarch                                                                                   8/20
  Verifying  : python-qpid-proton-0.16.0-7.el7.x86_64                                                                               9/20
  Verifying  : python-six-1.9.0-2.el7.noarch                                                                                       10/20
  Verifying  : katello-host-tools-3.0.2-2.el7sat.noarch                                                                            11/20
  Verifying  : python-gofer-proton-2.7.7-2.el7sat.noarch                                                                           12/20
  Verifying  : python-isodate-0.5.0-5.pulp.el7sat.noarch                                                                           13/20
  Verifying  : pulp-rpm-handlers-2.13.3-1.el7sat.noarch                                                                            14/20
  Verifying  : 1:python-html5lib-0.999-1.el7sat.noarch                                                                             15/20
  Verifying  : python-pulp-rpm-common-2.13.3-1.el7sat.noarch                                                                       16/20
  Verifying  : gofer-2.7.7-2.el7sat.noarch                                                                                         17/20
  Verifying  : tracer-common-0.6.13-2.el7sat.noarch                                                                                18/20
  Verifying  : python-beautifulsoup4-4.3.2-1.el7sat.noarch                                                                         19/20
  Verifying  : python-pulp-common-2.13.3-1.el7sat.noarch                                                                           20/20

Installed:
  katello-agent.noarch 0:3.0.2-2.el7sat

Dependency Installed:
  gofer.noarch 0:2.7.7-2.el7sat                                          katello-host-tools.noarch 0:3.0.2-2.el7sat
  katello-host-tools-fact-plugin.noarch 0:3.0.2-2.el7sat                 pulp-rpm-handlers.noarch 0:2.13.3-1.el7sat
  python-argcomplete.noarch 0:1.7.0-1.el7sat                             python-beautifulsoup4.noarch 0:4.3.2-1.el7sat
  python-gofer.noarch 0:2.7.7-2.el7sat                                   python-gofer-proton.noarch 0:2.7.7-2.el7sat
  python-html5lib.noarch 1:0.999-1.el7sat                                python-isodate.noarch 0:0.5.0-5.pulp.el7sat
  python-psutil.x86_64 0:5.0.1-1.el7sat                                  python-pulp-agent-lib.noarch 0:2.13.3-1.el7sat
  python-pulp-common.noarch 0:2.13.3-1.el7sat                            python-pulp-rpm-common.noarch 0:2.13.3-1.el7sat
  python-qpid-proton.x86_64 0:0.16.0-7.el7                               python-six.noarch 0:1.9.0-2.el7
  python2-tracer.noarch 0:0.6.13-2.el7sat                                qpid-proton-c.x86_64 0:0.16.0-7.el7
  tracer-common.noarch 0:0.6.13-2.el7sat

Complete!

3. # rpm -qa | grep katello-agent
katello-agent-3.0.2-2.el7sat.noarch

Successfully installed katello-agent on content host syncing satellite 6 tools repo/capsule repo and rhel base os repo.
Comment 4 Bryan Kearney 2018-02-21 12:09:43 EST
Since the problem described in this bug report should be resolved in a recent advisory, it has been closed with a resolution of ERRATA.

For information on the advisory, and where to find the updated files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHSA-2018:0336

Note You need to log in before you can comment on or make changes to this bug.