Bug 1459421 - The installer fails to download Kickstart files from URLs containing ampersands
The installer fails to download Kickstart files from URLs containing ampersands
Status: CLOSED DUPLICATE of bug 1443485
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: anaconda (Show other bugs)
7.4
x86_64 Linux
medium Severity medium
: beta
: 7.4
Assigned To: Anaconda Maintenance Team
Release Test Team
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2017-06-07 02:17 EDT by Supreet
Modified: 2017-06-07 06:23 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-06-07 06:23:04 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Supreet 2017-06-07 02:17:21 EDT
Description of problem:

The installers for RHEL 7.2 and RHEL 7.3 have no problem with this (using the ks boot parameter), but the installer of the RHEL 7.4 beta fails with this message:

dracut-initqueue: /lib/dracut/hooks/initqueue/fetch-ks-eth3.sh: line 5: 
syntax error near unexpected token '&'
dracut-initqueue: /lib/dracut/hooks/initqueue/fetch-ks-eth3.sh: line 5: 
'for kickstart in http://example.com/foo?bar&baz; do'


Version-Release number of selected component (if applicable):
RHEL 7.4 beta

How reproducible:
Boot with the RHEL 7.4 installer and append the ks parameter having '&' in it and it will fail with the same error.

Actual results:
It should fetch the kickstart

Expected results:
It's not fetching the kickstart and fails with above error

Additional info:
Comment 2 Radek Vykydal 2017-06-07 03:40:36 EDT
This issue has been fixed post-beta (anaconda-21.48.22.112-1) in bug 1443485. the fix should be included in Snapshot 1.
Comment 3 Samantha N. Bueno 2017-06-07 06:23:04 EDT

*** This bug has been marked as a duplicate of bug 1443485 ***

Note You need to log in before you can comment on or make changes to this bug.