Bug 145947 - system will not boot
system will not boot
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
4
All Linux
medium Severity medium
: ---
: ---
Assigned To: Dave Jones
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-01-24 06:20 EST by Need Real Name
Modified: 2015-01-04 17:16 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-04-08 17:25:23 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
hardware info (16.08 KB, text/plain)
2005-01-24 06:23 EST, Need Real Name
no flags Details
hardware info (23.82 KB, text/plain)
2005-01-24 06:27 EST, Need Real Name
no flags Details

  None (edit)
Description Need Real Name 2005-01-24 06:20:23 EST
I have a brand new box which I have installed FC3 onto.
The rescue disk works fine to bring up the network card, etc, and I
have been using it along with chroot to troubleshoot this problem.

FC3 refuses to boot, and hangs on every opportunity.
I have tried a "set -x" at the top of /etc/rc.sysinit, and this has
led to a never ending loop of commenting out things and adding items
to /etc/hotplug/blacklist.

The whole Sound section is commented out, as is raidautorun.
I have got as far as commenting out line 225, with "mount -n
/dev/pts", but since I'm only 23% through the script, I thought I best
post something here.

I will attach some output from dmesg, lspci, etc

Thanks
Comment 1 Need Real Name 2005-01-24 06:23:00 EST
Created attachment 110115 [details]
hardware info

lspci, lsmod, dmidecode
Comment 2 Need Real Name 2005-01-24 06:27:52 EST
Created attachment 110116 [details]
hardware info
Comment 3 Bill Nottingham 2005-01-25 01:08:33 EST
Where specifically does it hang, without any debugging/commenting?
Comment 4 Need Real Name 2005-01-25 03:04:11 EST
set -x is on, everything else is off. The last five lines:

+ fgrep -xq tg3 /etc/hotplug/blacklist
+ modprobe tg3
+ echo -n ' network'
 network ++ /sbin/modprobe -c
++ awk ' /^alias[[:space:]]+snd-card-[[:digit:]]+[[:space:]]/ { print
$3 }'

It hangs here.
Comment 5 Bill Nottingham 2005-01-25 10:03:41 EST
Odd. If you boot with init=/bin/bash, does the same command hang?
Comment 6 Need Real Name 2005-01-25 10:41:04 EST
Booting with init=/bin/bash works.
If I run both modprobe tg3, and modprobe -c, both work.

Do you want the output?
Comment 7 Bill Nottingham 2005-01-25 10:48:36 EST
No. If you take out the -x, it just hangs at the 'network' output?
Comment 8 Need Real Name 2005-01-25 10:55:14 EST
Yes:

Starting udev: [ OK ]
Initializing hardware... storage network

with a flashing underscore.

Pressing numlock on my keyboard doesn't turn on numlock (not sure if
it should yet though). Pressing enter does nothing too.
Comment 9 Need Real Name 2005-01-25 11:01:29 EST
Not sure if this helps, but Debian unstable 2.6 (Since removed) boots
okay.
Comment 10 Need Real Name 2005-01-28 07:07:30 EST
I've tried kernel 2.6.10-1.1110_FC4 from rawhide.

I see the same problem, but also notice that starting udev takes about
ten seconds.
Comment 11 Need Real Name 2005-01-28 07:08:32 EST
Make that half a minute.
Comment 12 Need Real Name 2005-01-31 06:15:41 EST
Same with kernel-2.6.10-1.1115_FC4.i686.

How can I troubleshoot this - if it was a program, I'd run strace.
Comment 13 Need Real Name 2005-02-03 11:21:55 EST
I'm pretty sure the broadcom gigabit network card is causing the problem.
Comment 14 Need Real Name 2005-04-04 10:19:12 EDT
Hm. Works in FC4T1.

Want me to mark as CURRENTRELEASE, or are you interested in fixing this for FC3?
Comment 15 Need Real Name 2005-04-08 17:25:23 EDT
I don't think this is going to get fixed. Marking as CURRENTRELEASE.

Note You need to log in before you can comment on or make changes to this bug.