Bug 145947 - system will not boot
Summary: system will not boot
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel
Version: 4
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Dave Jones
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-01-24 11:20 UTC by Need Real Name
Modified: 2015-01-04 22:16 UTC (History)
1 user (show)

(edit)
Clone Of:
(edit)
Last Closed: 2005-04-08 21:25:23 UTC


Attachments (Terms of Use)
hardware info (16.08 KB, text/plain)
2005-01-24 11:23 UTC, Need Real Name
no flags Details
hardware info (23.82 KB, text/plain)
2005-01-24 11:27 UTC, Need Real Name
no flags Details

Description Need Real Name 2005-01-24 11:20:23 UTC
I have a brand new box which I have installed FC3 onto.
The rescue disk works fine to bring up the network card, etc, and I
have been using it along with chroot to troubleshoot this problem.

FC3 refuses to boot, and hangs on every opportunity.
I have tried a "set -x" at the top of /etc/rc.sysinit, and this has
led to a never ending loop of commenting out things and adding items
to /etc/hotplug/blacklist.

The whole Sound section is commented out, as is raidautorun.
I have got as far as commenting out line 225, with "mount -n
/dev/pts", but since I'm only 23% through the script, I thought I best
post something here.

I will attach some output from dmesg, lspci, etc

Thanks

Comment 1 Need Real Name 2005-01-24 11:23:00 UTC
Created attachment 110115 [details]
hardware info

lspci, lsmod, dmidecode

Comment 2 Need Real Name 2005-01-24 11:27:52 UTC
Created attachment 110116 [details]
hardware info

Comment 3 Bill Nottingham 2005-01-25 06:08:33 UTC
Where specifically does it hang, without any debugging/commenting?

Comment 4 Need Real Name 2005-01-25 08:04:11 UTC
set -x is on, everything else is off. The last five lines:

+ fgrep -xq tg3 /etc/hotplug/blacklist
+ modprobe tg3
+ echo -n ' network'
 network ++ /sbin/modprobe -c
++ awk ' /^alias[[:space:]]+snd-card-[[:digit:]]+[[:space:]]/ { print
$3 }'

It hangs here.

Comment 5 Bill Nottingham 2005-01-25 15:03:41 UTC
Odd. If you boot with init=/bin/bash, does the same command hang?


Comment 6 Need Real Name 2005-01-25 15:41:04 UTC
Booting with init=/bin/bash works.
If I run both modprobe tg3, and modprobe -c, both work.

Do you want the output?

Comment 7 Bill Nottingham 2005-01-25 15:48:36 UTC
No. If you take out the -x, it just hangs at the 'network' output?

Comment 8 Need Real Name 2005-01-25 15:55:14 UTC
Yes:

Starting udev: [ OK ]
Initializing hardware... storage network

with a flashing underscore.

Pressing numlock on my keyboard doesn't turn on numlock (not sure if
it should yet though). Pressing enter does nothing too.

Comment 9 Need Real Name 2005-01-25 16:01:29 UTC
Not sure if this helps, but Debian unstable 2.6 (Since removed) boots
okay.

Comment 10 Need Real Name 2005-01-28 12:07:30 UTC
I've tried kernel 2.6.10-1.1110_FC4 from rawhide.

I see the same problem, but also notice that starting udev takes about
ten seconds.

Comment 11 Need Real Name 2005-01-28 12:08:32 UTC
Make that half a minute.

Comment 12 Need Real Name 2005-01-31 11:15:41 UTC
Same with kernel-2.6.10-1.1115_FC4.i686.

How can I troubleshoot this - if it was a program, I'd run strace.

Comment 13 Need Real Name 2005-02-03 16:21:55 UTC
I'm pretty sure the broadcom gigabit network card is causing the problem.

Comment 14 Need Real Name 2005-04-04 14:19:12 UTC
Hm. Works in FC4T1.

Want me to mark as CURRENTRELEASE, or are you interested in fixing this for FC3?

Comment 15 Need Real Name 2005-04-08 21:25:23 UTC
I don't think this is going to get fixed. Marking as CURRENTRELEASE.


Note You need to log in before you can comment on or make changes to this bug.