Bug 1459479 - [abrt] fabric: fabfile.py:21:host_type:NameError: global name 'run' is not defined
[abrt] fabric: fabfile.py:21:host_type:NameError: global name 'run' is not de...
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: fabric (Show other bugs)
25
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Athmane Madjoudj
Fedora Extras Quality Assurance
https://retrace.fedoraproject.org/faf...
abrt_hash:f6db8e14fcf544a6ce9a555e75f...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2017-06-07 05:20 EDT by bitchecker
Modified: 2017-07-29 13:40 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-07-29 13:40:30 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: backtrace (739 bytes, text/plain)
2017-06-07 05:20 EDT, bitchecker
no flags Details
File: environ (3.62 KB, text/plain)
2017-06-07 05:20 EDT, bitchecker
no flags Details

  None (edit)
Description bitchecker 2017-06-07 05:20:16 EDT
Version-Release number of selected component:
fabric-1.12.1-0.fc25

Additional info:
reporter:       libreport-2.8.0
cmdline:        /usr/bin/python2 /usr/bin/fab -H 178.32.139.194 host_type
executable:     /usr/bin/fab
kernel:         4.11.3-200.fc25.x86_64
pkg_fingerprint: 4089 D8F2 FDB1 9C98
pkg_vendor:     Fedora Project
runlevel:       N 5
type:           Python
uid:            1000

Truncated backtrace:
fabfile.py:21:host_type:NameError: global name 'run' is not defined

Traceback (most recent call last):
  File "/usr/lib/python2.7/site-packages/fabric/main.py", line 756, in main
    *args, **kwargs
  File "/usr/lib/python2.7/site-packages/fabric/tasks.py", line 386, in execute
    multiprocessing
  File "/usr/lib/python2.7/site-packages/fabric/tasks.py", line 276, in _execute
    return task.run(*args, **kwargs)
  File "/usr/lib/python2.7/site-packages/fabric/tasks.py", line 173, in run
    return self.wrapped(*args, **kwargs)
  File "/media/Multimedia/Programmazione/PYTHON/software/monitoring/fabfile.py", line 21, in host_type
    run('uname -a')
NameError: global name 'run' is not defined

Local variables in innermost frame:
Comment 1 bitchecker 2017-06-07 05:20:23 EDT
Created attachment 1285721 [details]
File: backtrace
Comment 2 bitchecker 2017-06-07 05:20:25 EDT
Created attachment 1285722 [details]
File: environ
Comment 3 Athmane Madjoudj 2017-07-29 13:40:30 EDT
It seems to be error in the script (syntax / runtime / etc...)
Closing for now, if you think that it a real bug, please attach a reproducible code snippet.

Note You need to log in before you can comment on or make changes to this bug.