Bug 1459497 - [abrt] fabric: main.py:167:load_fabfile: File "/media/Multimedia/Programmazione/PYTHON/software/monitoring/fabfile.py", line 43
Summary: [abrt] fabric: main.py:167:load_fabfile: File "/media/Multimedia/Programmazi...
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: fabric   
(Show other bugs)
Version: 25
Hardware: x86_64
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Athmane Madjoudj
QA Contact: Fedora Extras Quality Assurance
URL: https://retrace.fedoraproject.org/faf...
Whiteboard: abrt_hash:90631e6f5f026c69f1a96e19e8c...
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-06-07 09:59 UTC by bitchecker
Modified: 2017-07-29 17:49 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-07-29 17:49:18 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: backtrace (887 bytes, text/plain)
2017-06-07 09:59 UTC, bitchecker
no flags Details
File: environ (3.62 KB, text/plain)
2017-06-07 09:59 UTC, bitchecker
no flags Details

Description bitchecker 2017-06-07 09:59:26 UTC
Version-Release number of selected component:
fabric-1.12.1-0.fc25

Additional info:
reporter:       libreport-2.8.0
cmdline:        /usr/bin/python2 /usr/bin/fab -R cliente1 package
executable:     /usr/bin/fab
kernel:         4.11.3-200.fc25.x86_64
pkg_fingerprint: 4089 D8F2 FDB1 9C98
pkg_vendor:     Fedora Project
runlevel:       N 5
type:           Python
uid:            1000

Truncated backtrace:
main.py:167:load_fabfile:  File "/media/Multimedia/Programmazione/PYTHON/software/monitoring/fabfile.py", line 43

Traceback (most recent call last):
  File "/usr/lib/python2.7/site-packages/fabric/main.py", line 666, in main
    docstring, callables, default = load_fabfile(fabfile)
  File "/usr/lib/python2.7/site-packages/fabric/main.py", line 167, in load_fabfile
    imported = importer(os.path.splitext(fabfile)[0])
  File "/media/Multimedia/Programmazione/PYTHON/software/monitoring/fabfile.py", line 43
    def package(package="bash")
                              ^
SyntaxError: invalid syntax

Local variables in innermost frame:
index: None
importer: <built-in function __import__>
directory: '/media/Multimedia/Programmazione/PYTHON/software/monitoring'
path: '/media/Multimedia/Programmazione/PYTHON/software/monitoring/fabfile.py'
fabfile: 'fabfile.py'
added_to_path: True

Comment 1 bitchecker 2017-06-07 09:59:32 UTC
Created attachment 1285734 [details]
File: backtrace

Comment 2 bitchecker 2017-06-07 09:59:34 UTC
Created attachment 1285735 [details]
File: environ

Comment 3 Athmane Madjoudj 2017-07-29 17:49:18 UTC
It seems to be error in the script (syntax / runtime / etc...)
Closing for now, if you think that it a real bug, please attach a reproducible code snippet.


Note You need to log in before you can comment on or make changes to this bug.