Bug 1459509 - [abrt] fabric: operations.py:381:put:ValueError: '/media/Multimedia/Programmazione/PYTHON/software/monitoringmonitor.sh' is not a valid local path or glob.
[abrt] fabric: operations.py:381:put:ValueError: '/media/Multimedia/Programma...
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: fabric (Show other bugs)
25
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Athmane Madjoudj
Fedora Extras Quality Assurance
https://retrace.fedoraproject.org/faf...
abrt_hash:e720c550a8102cc949387fcddca...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2017-06-07 06:27 EDT by bitchecker
Modified: 2017-07-29 13:51 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-07-29 13:51:54 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: backtrace (1.50 KB, text/plain)
2017-06-07 06:27 EDT, bitchecker
no flags Details
File: environ (3.62 KB, text/plain)
2017-06-07 06:27 EDT, bitchecker
no flags Details

  None (edit)
Description bitchecker 2017-06-07 06:27:13 EDT
Version-Release number of selected component:
fabric-1.12.1-0.fc25

Additional info:
reporter:       libreport-2.8.0
cmdline:        /usr/bin/python2 /usr/bin/fab -R cliente1 monitor
executable:     /usr/bin/fab
kernel:         4.11.3-200.fc25.x86_64
pkg_fingerprint: 4089 D8F2 FDB1 9C98
pkg_vendor:     Fedora Project
runlevel:       N 5
type:           Python
uid:            1000

Truncated backtrace:
operations.py:381:put:ValueError: '/media/Multimedia/Programmazione/PYTHON/software/monitoringmonitor.sh' is not a valid local path or glob.

Traceback (most recent call last):
  File "/usr/lib/python2.7/site-packages/fabric/main.py", line 756, in main
    *args, **kwargs
  File "/usr/lib/python2.7/site-packages/fabric/tasks.py", line 386, in execute
    multiprocessing
  File "/usr/lib/python2.7/site-packages/fabric/tasks.py", line 276, in _execute
    return task.run(*args, **kwargs)
  File "/usr/lib/python2.7/site-packages/fabric/tasks.py", line 173, in run
    return self.wrapped(*args, **kwargs)
  File "/media/Multimedia/Programmazione/PYTHON/software/monitoring/fabfile.py", line 50, in monitor
    put(script, "monitor.sh")
  File "/usr/lib/python2.7/site-packages/fabric/network.py", line 683, in host_prompting_wrapper
    return func(*args, **kwargs)
  File "/usr/lib/python2.7/site-packages/fabric/operations.py", line 381, in put
    raise ValueError(err)
ValueError: '/media/Multimedia/Programmazione/PYTHON/software/monitoringmonitor.sh' is not a valid local path or glob.

Local variables in innermost frame:
mirror_local_mode: False
ftp: <fabric.sftp.SFTP object at 0x7f6355d41710>
err: "'/media/Multimedia/Programmazione/PYTHON/software/monitoringmonitor.sh' is not a valid local path or glob."
local_path: '/media/Multimedia/Programmazione/PYTHON/software/monitoringmonitor.sh'
use_sudo: False
remote_path: '/tmp/monitor.sh'
local_is_path: True
names: []
temp_dir: ''
home: u'/home/ciro'
use_glob: True
mode: None
Comment 1 bitchecker 2017-06-07 06:27:19 EDT
Created attachment 1285747 [details]
File: backtrace
Comment 2 bitchecker 2017-06-07 06:27:21 EDT
Created attachment 1285748 [details]
File: environ
Comment 3 Athmane Madjoudj 2017-07-29 13:51:54 EDT
It seems to be error in the script (syntax / runtime / etc...)
Closing for now, if you think that it a real bug, please attach a reproducible code snippet.

Note You need to log in before you can comment on or make changes to this bug.