Bug 1459612 - SmartState Analysis fails with undefined method `vhd' for Azure Windows instances/VMs
SmartState Analysis fails with undefined method `vhd' for Azure Windows insta...
Status: CLOSED DUPLICATE of bug 1475540
Product: Red Hat CloudForms Management Engine
Classification: Red Hat
Component: SmartState Analysis (Show other bugs)
5.8.0
Unspecified Unspecified
high Severity high
: GA
: cfme-future
Assigned To: Jerry Keselman
Satyajit Bulage
azure:smartstate
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2017-06-07 11:00 EDT by ncatling
Modified: 2017-09-05 09:02 EDT (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-09-05 09:02:32 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: Azure


Attachments (Terms of Use)

  None (edit)
Description ncatling 2017-06-07 11:00:49 EDT
Description of problem:
SmartState Analysis of Azure Windows VMs fails with:
undefined method `vhd' for #<Azure::Armrest::VirtualMachineModel::Properties::StorageProfile::OsDisk:0x0000000ede9d98>

Version-Release number of selected component (if applicable):
5.8.0.17

How reproducible:


Steps to Reproduce:
1. SSA any Windows VM on Azure provider
2. Error produced
3.

Actual results:
ERROR -- : MIQ(MiqServer#scan_metadata) undefined method `vhd' for #<Azure::Armrest::VirtualMachineModel::Properties::StorageProfile::OsDisk:0x0000000ede9d98>
ERROR -- : MIQ(VmScan#process_abort) job aborting, undefined method `vhd' for #<Azure::Armrest::VirtualMachineModel::Properties::StorageProfile::OsDisk:0x0000000ede9d98>

Expected results:


Additional info:
Comment 3 Jeff Teehan 2017-06-16 10:22:34 EDT
This problem isn't global.  SSA is working fine on multiple appliances.  We're going to need a little more information.  Output for 2012 and 2016

Status = Ok	06/15/17 23:05:35 UTC	06/15/17 22:53:24 UTC	06/15/17 22:53:17 UTC	finished	Process completed successfully	Scan from Vm WS2016SSA	admin	EVM	Synchronization complete
Status = Ok	06/15/17 22:36:32 UTC	06/15/17 22:15:53 UTC	06/15/17 22:15:44 UTC	finished	Process completed successfully	Scan from Vm WS2012R2SSA	admin	EVM	Synchronization complete
Comment 5 Rich Oliveri 2017-08-02 13:53:03 EDT
Jerry,

I think this is related to the manage storage issues you're looking into.
Comment 6 Jerry Keselman 2017-08-02 14:01:35 EDT
Yes.  This is the error one would get attempting to run SSA against a VM with a Managed Disk.  Working on a fix right now.
Comment 7 Krain Arnold 2017-08-18 02:59:43 EDT
For what it's worth, I'm seeing this consistently as well, and on RHEL and Ubuntu workloads so the problem is not only affecting Windows machines. The error is consistent: undefined method `vhd' for #<Azure::Armrest::VirtualMachineModel::Properties::StorageProfile::OsDisk.....
Comment 8 Jerry Keselman 2017-09-05 09:02:32 EDT
This BZ is a duplicate of https://bugzilla.redhat.com/show_bug.cgi?id=1475540 in which the fixes for this issue are being tracked.   Closing this one in lieu of the other BZ.

*** This bug has been marked as a duplicate of bug 1475540 ***

Note You need to log in before you can comment on or make changes to this bug.